Toolchain problem when building custom kernel with 34.1.1 / 34.1.0

Hi,
I’m trying to build a custom kernel image for a custom carrier board using an Ubuntu host. I did it successfully with the 32.4.4 L4T but now with the latest Jetpack (34.1.1/34.1.0 L4Ts) I face some problems regarding the toolchain:

  1. The developer guide states two different env variables regarding the toolchain:
    1.1. export CROSS_COMPILE_AARCH64_PATH=/aarch64–glibc–stable-2020.08-1 (from building kernel section)
    1.2. tar xf aarch64–glibc–stable-2020.08-1.tar.bz2
    export CROSS_COMPILE=$HOME/l4t-gcc/bin/aarch64-buildroot-linux-gnu-

Which one to use?

  1. I tried to export both of them/one of them and faced the following problems:
    2.1. the nvbuild.sh and nvcommonbuild.sh didn’t recognize the exported env variables.
    2.2. I added the export command to the nvbuild.sh itself and it complained that it couldn’t find the required toolchain path with a path composed of both env variables attached together to one string.

I need some help with this issues.

Thanks.

Please refer to Something wrong with cross_compile_aarch64_path in document - Jetson & Embedded Systems / Jetson Xavier NX - NVIDIA Developer Forums

It worked. Thank you