Torch install problem on Jetson TK1

Not strictly on topic, but I though maybe someone might be able to help.

I’m trying to get started on a Jetson board and seem to have hit a brick wall when installing Torch.

Working directly on the board itself, Ubuntu 14.04.3 LTS, running Torch’s install.sh stops at the following:

Missing dependencies for nn:
luaffi

Using https://raw.githubusercontent.com/torch/rocks/master/luaffi-scm-1.rockspec… switching to ‘build’ mode
Cloning into ‘luaffifb’…
remote: Counting objects: 42, done.
remote: Compressing objects: 100% (39/39), done.
remote: Total 42 (delta 4), reused 29 (delta 2), pack-reused 0
Receiving objects: 100% (42/42), 159.09 KiB | 0 bytes/s, done.
Resolving deltas: 100% (4/4), done.
Checking connectivity… done.
gcc -O2 -fPIC -I/home/danny/torch/install/include -c call.c -o call.o -Idynasm
call.c:47:22: fatal error: call_arm.h: No such file or directory
#include “call_arm.h”
^
compilation terminated.

I’ve tried just luarocks install luaffi, same error.

Any suggestions?

More - my immediate goal is getting this running on the Jetson:

https://github.com/karpathy/char-rnn

I had it running on my non-CUDA laptop not long ago (https://dannyayers.wordpress.com/2015/05/30/recurrent-neural-network-writes-w3c-semantic-web-specification/) so reproducing that on CUDA seemed like a good foothold.

I think I got Torch installed at one point, but char-nn couldn’t see cutorch & cunn, a suggestion I found somewhere was upgrading cmake to version 3.2.2. So I did that, started again, and hit the issue. But then reverting to cmake version 2.8.12.2 leaves me still with the error above.

As far as I can tell CUDA 6.5 is installed ok -

dpkg -i cuda-repo-l4t-r21.2-6-5-prod_6.5-34_armhf.deb

$ nvcc --version
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2014 NVIDIA Corporation
Built on Wed_Nov_12_15:57:57_CST_2014
Cuda compilation tools, release 6.5, V6.5.30

Cheers,
Danny.

Hi danja,
Would you please file this topic into the CUDA Setup and Installation board - https://devtalk.nvidia.com/default/board/58/ ?
This could help to get the corresponding reply correct and better.

Cheers.

Hi Danny,
Several months ago I did a video on installing Torch on the TK1:


Of course things may have changed since then, but it might be worth reviewing. At the time, things seemed to work out correctly.