Torchvision compatibility problem with jetpack 5.1.1 and torch 1.14 on nvidia xavier nx

Hi I’m having issues with getting my nvidia xavier nx working with torchvision.

currently running:
jetpack: 5.1.1
ubuntu: 20.04
torch: 1.14.0a0+44dac51c.nv23.04 (have tried the 2.0 version as well)
python: 3.8
cuda: 11.4 (have tried cuda 11.8)

the current torchvision version: 0.15.1

I am trying to build torchvision from source and after installation and running some code with yolov7 model i get compatibility errors. I tried searching everywhere but couldn’t find a good answer. Is there a way i can resolve this issue as the normal torch version would not detect the GPU and only these nvidia released version work? Or do i need to install an older version of jetpack and try with different packages and see if that works?

downloaded torch from this page:
torch nvidia

note: the normal torch cuda versions from the pytorch site dont work as they can’t detect the GPUfor some reason.

Hi @robinmorais, the normal torch wheels for aarch64 from or pip/PyPi aren’t built with CUDA enabled, which is why they won’t detect the GPU. Those other PyTorch wheels that we provide are built with CUDA enabled.

Can you try uninstalling torchvision and building it from source like shown under the Installation section of this post:

For PyTorch 2.0, I’ve used torchvision v0.15.1, but for PyTorch 1.14 you might want to use torchvision v0.14.1 if you are having problems. Also if you continue having issues, you could try using the l4t-pytorch container which already has PyTorch/torchvision pre-installed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.