Traffic light detection using YOLO3 model in autonomous Vehicle

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
[.] NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
[.] Linux
QNX
other

Hardware Platform
[.] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.9.1.10844
[.] other

Host Machine Version
[.] native Ubuntu 18.04
other

Environment setup:
Software Version = DRIVE OS Linux 5.1.6 and DriveWorks 2.2
Target Operating System = Linux
Hardware Platform = NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
SDK Manager Version = 1.8.1.10392
Host Machine Version = Ubuntu 18.04
DRIVE_Software_10.0_Linux_OS_DRIVE_AGX_XAVIER
cuda version = 10.2
python version= 2.7,3.6

We are working Traffic light detection and classification using YOLO3 model in host and target.While running the traffic light node is looking for dependencies of TensorRT .TensorRT has a specific Python>=3.7 version is required.

If I install Python>=3.7 in target and host, will I have any compatibility issues with Python versions.

Kindly clarify.

In case of incompatibility, kindly the alternate solution to use Yolo models for detection.

Thanks

Dear @kagitala.varalakshmi1,
TensorRT Python bindings are not supported on target. How do you plan to verify your model on target? Do you plan to use TensorRT/Driveworks on target? Is it possible to upgrade to latest DRIVE OS 5.2.6 + DW 4.0 release?

TensorRT has a specific Python>=3.7 version is required.

Is this TensorRT installed using sdkmanager or using x86 release?

we are using driveworks-2.2 on target ,we are tried running this(“sample_light_classifier”) sample was not able to detect and classify most of the time.

upgrading DRIVE OS 5.2.6 + DW 4.0 on the target may not be possible.
rest of the system it will work Driveworks2.2

we are not installed TensorRT on traget.

Thanks for your reply.