Tried CUDA 2.1 with current driver.... Some example compiles, but crash

I may not have the right driver because the one to download on CUDA download page doesn’t recognize the graphic card on my laptop (9800M GTS).

I installed and tried CUDA 2.1 and manage to compile some projects. Some have missing files and can’t thus be compiled ?!
Though, those that could be compiled and apparently producing output would not run and crash with an exception.
Kind of cudaError_enum at some address and cudaError. The last one I tried was Mandelbrot.
Doc contains no document, just images.

This is when compiling the Debug version.

Compiling the Release version simply fails ! The linker complains that it can’t open the .exe file ?!

This is all so crappy, I can’t believe it !

I tried the latest driver I could find for my laptop here here http://www.nvidia.com/object/notebook_drivers.html
version 179.28 Beta, but when I try to run the examples none of them work or they give bad results.

For instance the simpleGL example manage to open a window but shows only a tiny red dot in the center.
Many programs simply stop working.

So I can’t even run the precompiled examples !

For instance here is what I get

C:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\bin\win32\Release>smokeParticles.exe
Loaded ‘…/…/…/projects/smokeParticles/data/floortile.ppm’, 256 x 256 pixels
cudaSafeCall() Runtime API error in file <ParticleSystem.cu>, line 111 : invalid texture reference.

OOPs ! In release note files I see this :

OK.

Where do I get this driver for 9800M GTS graphic card ?

Apparently, 179.28 is the latest I managed to find.

Problem solved.

On http://www.laptopvideo2go.com one can get .INF files to replace in the Nvidia driver for desktop so that it can be installed also on notebooks.

Examples now run perfectly.