Triton TAO compatibility

Please provide complete information as applicable to your setup.

• Hardware Platform ( GPU)
• DeepStream Version 6.1.1
• JetPack Version (valid for Jetson only)
• TensorRT Version 8.4.2. vs 8.4.3
• NVIDIA GPU Driver Version (valid for GPU only) 515.65.01
• Issue Type( questions, new requirements, bugs) incompatibility
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Is there a Deepstream6.1.1 compatible Triton docker image on NGC catalog? Currently I found Triton with TensorRT 8.4.2, but Deepstream6.1.1. requires TensorRT 8.4.3.

I trained a yolov4 model with TAO, that can run with Deepstream6.1.1, but I was not able to find a correspondent Triton docker image.

I found a workaround.

Exactly this tao-converter script can work:

I should copy the .etlt file into the Triton docker image and convert inside that. And later the tritonserver was able to use the converted model (.engine)

1 Like

So, is this issue solved for you?

more or less

the main issue that there is still no any downloadable compatible Triton docker image with Deepstream6.1.1

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one.

There is, you can find from:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.