Trouble executing debug version

I have difficulty in executing the debug version (the optmised, non-debug version works correctly).

When executed, “Segmentation fault” is produced and nothing else.
When took it through the debugger the following was shown.
Signalled SIGSEGV at 0x2BA8B814D590, function ___rouent2, file …/…/prof/rouent_c.c, line 72
Complete message included at the end.

FORTRAN source files; Linux SLED10.2, PGI 10.1, glibc 2.4,

Tried linking with the libraries shown below but didn’t help
-lpgc -lpgf90_prof -lpgnod_prof -lpgnod_prof_time -lpgnod_prof_g -lc -lm

Any suggestion would be appreciated.

Complete message from debugger.

pgdbg> run MAIN.INP
librsl.so loaded by ld-linux-x86-64.so.2.
libsdf.so loaded by ld-linux-x86-64.so.2.
libru.so loaded by ld-linux-x86-64.so.2.
libpgc.so loaded by ld-linux-x86-64.so.2.
libpgf90_prof.so loaded by ld-linux-x86-64.so.2.
libpgnod_prof.so loaded by ld-linux-x86-64.so.2.
libpgnod_prof_time.so loaded by ld-linux-x86-64.so.2.
libpgnod_prof_g.so loaded by ld-linux-x86-64.so.2.
libc.so.6 loaded by ld-linux-x86-64.so.2.
libmif.so loaded by ld-linux-x86-64.so.2.
libdl.so.2 loaded by ld-linux-x86-64.so.2.
libpgf90.so loaded by ld-linux-x86-64.so.2.
libpgf90_rpm1.so loaded by ld-linux-x86-64.so.2.
libpgf902.so loaded by ld-linux-x86-64.so.2.
libpgf90rtl.so loaded by ld-linux-x86-64.so.2.
libpgftnrtl.so loaded by ld-linux-x86-64.so.2.
librt.so.1 loaded by ld-linux-x86-64.so.2.
libpthread.so.0 loaded by ld-linux-x86-64.so.2.
libm.so.6 loaded by ld-linux-x86-64.so.2.
Signalled SIGSEGV at 0x2BA8B814D590, function ___rouent2, file …/…/prof/rouent_c.c, line 72
0x2BA8B814D590: 4C 8B 70 8 movq 8(%rax),%r14
pgdbg>

Hi PJawahar,

Without further investigation it unclear why the code would be seg faulting here. I’ve sent this on to one of our engineers but we’ll most likely need an example code in order to diagnose the problem. If you’re able, please send an example to PGI Customer Support at trs@pgroup.com.

The “rounent” routines are used in profiling so you should be able to work around the problem by removing the “-Mprof” flag from your compilation and link.

Thanks,
Mat

Mat,
Many Thanks. Dropping “-Mprof” option works.

I am not sure if I can create an example with which I can reproduce the problem. I, certainly, would contact PGI customer support with more information.

Jawahar