Trouble of getting VScode and VScode Pylance work

   I got some trouble of getting VScode Pylance work normally. For unknow reason, my .vscode is not been set properly. As the result, I can not have the autocomplete and can not run my code on VScode. When I try to run it will give an error: An Invalid Python interpreter is selected, please try changing it to enable features such as IntelliSense, linting, and debugging.

  Is there anyone can give me some instruction about that?

@Frank-Echo can you elaborate on the problems you are encountering?