Trouble on running Sample on egra_multimedia_api and argus\samples on Jetson TX1 Board

After install Jetson TX1 R28.2, I just want to test built-in camera OV5693 On Nvidia TX1 board.

I see some sample on the direction egra_multimedia_api:

  1. tegra_multimedia_api\samples
  2. tegra_multimedia_api\argus\samples

I try to running the sample tegra_multimedia_api\samples\10_camera_recording on Jetson TX1, But get following error message:

./camera_recording
Set governor to performance before enabling profiler
OFParserGetVirtualDevice: NVIDIA Camera virtual enumerator not found in proc device-tree
LoadOverridesFile: looking for override file [/Calib/camera_override.isp] 1/16LoadOverridesFile: looking for override file [/data/nvcam/settings/camera_overrides.isp] 2/16LoadOverridesFile: looking for override file [/opt/nvidia/nvcam/settings/camera_overrides.isp] 3/16LoadOverridesFile: looking for override file [/var/nvidia/nvcam/settings/camera_overrides.isp] 4/16LoadOverridesFile: looking for override file [/data/nvcam/camera_overrides.isp] 5/16LoadOverridesFile: looking for override file [/data/nvcam/settings/e3326_front_P5V27C.isp] 6/16LoadOverridesFile: looking for override file [/opt/nvidia/nvcam/settings/e3326_front_P5V27C.isp] 7/16LoadOverridesFile: looking for override file [/var/nvidia/nvcam/settings/e3326_front_P5V27C.isp] 8/16---- imager: No override file found. ----
PRODUCER: Creating output stream
PRODUCER: Launching consumer thread
Failed to query video capabilities: Inappropriate ioctl for device
NvMMLiteOpen : Block : BlockType = 4
===== MSENC =====
NvMMLiteBlockCreate : Block : BlockType = 4
875967048
842091865
create video encoder return true
CONSUMER: Waiting until producer is connected…
PRODUCER: Starting repeat capture requests.
CONSUMER: Producer has connected; continuing.
SCF: Error InvalidState: NonFatal ISO BW requested not set. Requested = 2147483647 Set = 2550000 (in src/services/power/PowerServiceCore.cpp, function setCameraBw(), line 653)
CONSUMER: Got EOS, exiting…
CONSUMER: Done.
PRODUCER: Done – exiting.


Total Profiling Time = 0 sec


Are there any document on following Items?

  1. What is the function feature with tegra_multimedia_api\samples?
    2 What is the function feature with tegra_multimedia_api\argus\samples and how to build and run those sample?

I also try to run a v4l2-ctl test on Jetson TX1
• Enter the command:
v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG12 --stream-mmap -set-ctrl=sensor_mode=0 --stream-count=100 -d /dev/video0

ubuntu@tegra-ubuntu:~$ v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG12 --stream-mmap -set-ctrl=sensor_mode=0 --stream-count=100 -d /dev/video
it say: Unknown standard ‘et-ctrl=sensor_mode=0’

Thanks,
Martin

Hi,
You have run it successfully. Please check presence of outout.h264

nvidia@tegra-ubuntu:~/tegra_multimedia_api/samples/10_camera_recording$ ls -all output.h264
-rw-rw-r-- 1 nvidia nvidia 505659 Mar 20 06:31 output.h264

And you can play it by running 00_video_decode

nvidia@tegra-ubuntu:~/tegra_multimedia_api/samples/00_video_decode$ export DISPLAY=:0
nvidia@tegra-ubuntu:~/tegra_multimedia_api/samples/00_video_decode$ ./video_decode H264 ../10_camera_recording/output.h264

Hi,

Thank you for your feedback.
Are there any document on the tegra_multimedia_api\argus\samples?
Just for sample feature and build and test steps.

Thanks,
Martin

Please check
https://developer.nvidia.com/embedded/dlc/l4t-documentation-28-2-ga
https://developer.nvidia.com/embedded/dlc/l4t-multimedia-api-reference-28-2-ga