Trouble setting up multi-video card system so CUDA-capable card can be in compute-only mode

So I was running a single GeForce 240 GT in Ubuntu, but was starting to hit the point where my code would time out due to the card also having display duties. My motherboard has an onboard graphics chip and I tried to enable that, but the motherboard would not boot with both the onboard chip turned on and a video card in the PCI-E slot, so I had to abandon that option. My board only has one PCI-E 16x slot, so that left using a standard PCI card for display duties as my only option.

I found a Matrox PCI video card lying around, tested that it worked correctly by itself, and then tried to install it in my CUDA system. When I boot with the monitor cable attached to the Matrox PCI video card, Ubuntu tells me that the graphics system is not configured properly, and I can either have it auto-configured, or run in some kind of “basic graphics” mode. Doing either option gets me to the desktop fine, but when I attempt to run a CUDA program I receive the error message that no CUDA device is available. If I reinstall the CUDA driver, at the next boot I simply get the “graphics system is not configured properly” error message again and am back in the same situation. I can reinstall the CUDA driver and boot with the cable attached to the 240 GT and then CUDA programs work again, but then I’m back in my initial situation where kernels will time out.

Can anyone help with the correct process to set up my system so the non-CUDA PCI video card has full display system duties, and the 240 GT is available for CUDA applications? Thanks!

The problem you are running into is missing device files in /dev. When you first install the driver, it makes them, as does the X server when you are using it with your GT240 as the display. For a compute-only system, you need to run a script at boot time as described in the release notes:

http://developer.download.nvidia.com/compu…notes_linux.txt

(Scan down to “Known Issues”)