Trouble with Gstreamer

I’m using Jetson Nano and test Gstreamer. But when I use the test command, It doesn’t show the test Image.

Jetpack:
R32 (release), REVISION: 5.1, GCID: 26202423, BOARD: t210ref, EABI: aarch64, DATE: Fri Feb 19 16:45:52 UTC 2021

Gstreamer:
GStreamer Core Library version 1.14.5

My test comman:
gst-launch-1.0 videotestsrc ! videoconvert ! autovideosink

log:
Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Pipeline is PREROLLED …
Setting pipeline to PLAYING …
New clock: GstSystemClock

What should I do?

Hi @kenpeter056 ,

Your pipeline seems to be running fine. May I ask, is there a display connected to the Jetson Nano? or are you connected to the board via ssh and want to display it in your computer?

In the case you have a display connected to the Nano, you can try with other sinks, for example:
gst-launch-1.0 videotestsrc ! videoconvert ! ximagesink
gst-launch-1.0 videotestsrc ! videoconvert ! nvoverlaysink

In the case you are connected via ssh and want to display on your local computer’s display, make sure to connect to the board with X11 Forwarding enabled, for example:
ssh -X <ip_address>

to verify X11 forwarding is enabled, after accessing the board with the previous command you can run:
echo $DISPLAY
The output should be defined and look something like this: “localhost:10.0”

And in this case you can use the following sink:
gst-launch-1.0 videotestsrc ! videoconvert ! xvimagesink

If you want to get more information and probably identify an issue with your piepeline you can run it with the debug enabled, for example:
GST_DEBUG=2 gst-launch-1.0 videotestsrc ! videoconvert ! xvimagesink

Regards,
Luis
Embedded SW Engineer at RidgeRun
Contact us: support@ridgerun.com
Developers wiki: https://developer.ridgerun.com/
Website: www.ridgerun.com

I’m using the VNC vierer through remote desk.
I tried connect a display to the Jetson Nano, all the command work.
And only this command "gst-launch-1.0 videotestsrc ! videoconvert ! nvoverlaysink"worked when I use the VNC viewer.
Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.