Troubles in installing deepstream 6.1.1 in jetpack 5.0.2

I found a guide document.
And I tried to follow the section - Install the DeepStream SDK.

When I try the method #2 - Method 2 : Using the DeepStream tar package:, I cannot extract the tbz2 file as guided:

$ sudo tar -xvf deepstream_sdk_v6.1.1_jetson.tbz2 -C /
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error is not recoverable: exiting now

<<<<< I’ve found the source of this problem. I downloaded the file via right-mouse-click and select ‘save as …’. But this was wrong. User must click left-mouse-button to download it.

When I try the method #3 - Method 3 : Using the DeepStream Debian package:, I cannot install it:

$ sudo apt-get install ./deepstream-6.1_6.1.1-1_arm64.deb
Reading package lists… Error!
E: Invalid archive signature
E: Internal error, could not locate member control.tar.{zstlz4gzxzbz2lzma}
E: Could not read meta data from /home/armstrong/Armstrong/a50/docker/build_swm/installers/dp/deepstream-6.1_6.1.1-1_arm64.deb
E: The package lists or status file could not be parsed or opened.

<<<<< I am now reading the guide document from the begging now. I guess this would be solved by myself soon.

I use Orin EVK / jetpack is 5.0.2

Thank you in advance!

We are moving this post to the DeepStream SDK forum to get better help on setup related issue.

Seems the deb file is not well downloaded, can you download again and re-install?

Hello yingliu,

You are right. So this issue is no more an issue. Thanks. But there is another problem I am now facing:

I still need some advice.
Thank you.

Let’s close this one and focus the docker topic.

I agree with you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.