Troubling with flashing Jetson TX2 with Elroy carrier support

I need to read APP partition from Jetson TX2 and flashing this image to Tegra, this or other.

I use r28.1 version.

When I make it with parameter “jetson-tx2” (flashing-read APP-write image), all is ok.
When I make flashing of Tegra without image and parameter “elroy-usb3” for flash.sh, it’s ok also.

I had tried different conditions to read and write image, but after flashing with image, what I’m reading, Tegra couldn’t start neither on devkit, nor on elroy. I make all actions on devkit, and use elroy for testing just.

Can I read images from Tegra which is flashed with Elroy support Package and write them to Tegra to use on Elroy carrier?

Thanks in advance.

hello DEngine,

please refer to this external wiki page, https://elinux.org/Jetson/TX2_Cloning
here’s “-G” command for you to read partition and save image to file,
you may also adding “-k” command to specify the partition names.
thanks

Hello JerryChang,

thanks for responding

To read, I use:

$ sudo ./flash.sh -r -k APP -G path_to_backup/system.img jetson-tx2 mmcblk0p1

and

$ sudo ./flash.sh -r -k APP -G path_to_backup/system.img elroy-usb3 mmcblk0p1

To write:

$ sudo ./flash.sh -r -k APP jetson-tx2 mmcblk0p1

and

$ sudo ./flash.sh -r -k APP elroy-usb3 mmcblk0p1

All actions were on devkit. Before to write hear, I’ve tried many combinations, also with working Tegra with 3rdParty and my soft and with Tegra that is just flashing. I have just two working opportunity:

  • read and write image for devkit (“jetson-tx2” parameter for flash.sh), but I need Tegra working on Elroy carrier,
  • and flashing Tegra without image for Elroy from zero, but it takes a lot of time (I need to install other soft and my soft also) - not enough good choose for me.

I think, most correct way is reading with “jetson-tx2” parameter and writing with “elroy-usb3”. I think some troubles in Elroy drivers, which does’t write again or overwrite by image, imho.

Hi DEngine, you may want to contact ConnectTech support to see if they have suggestions for cloning from Elroy carrier.

Hello dusty_nv, I’ve already done. While I don’t have a solution, I’m searching wherenever