Trying to build VisionWorks TK1 (on Project Tango)

Hello,

I am working on project Tango development using Tegra.
I have a question about nvidia extension of ​​OpenVX and how to run it on Google project Tango.
As of my understanding cuda 7 is not supported for TK1, and cuda > 6.0 is not enabled in Tango dev kit.
I was wondering how I can use VisonWorks (on host) for cross development. Is the current release supported for Tango? I tried to install it through the newest Jetpack 2.0 (under TK1 option) but VisionWorks installation keeps saying:

The following packages have unmet dependencies:
libvisionworks : Depends: cuda-cudart-7-0 but it is not installable

Is it supposed to only work on Jetson TK1/TX1 and not Tango? Why is it requiring cuda7? TK1 works with 6.5, doesn’t?
I also tried to resolve unmet packages by apt-get without success.

I’d appreciate your help to figure out how these things work.

I have no knowledge of tango, but FYI, CUDA 6.5 is the highest CUDA version supported on 32-bit ARMv7. The big change for CUDA 7 is that it requires 64-bit, e.g., a desktop computer or a Jetson TX1.

JetPack 2.0 is installing different versions of CUDA and VisonWorks on Jetson TK1/TX1.

TK1:
CUDA 6.5
libvisionworks-repo_{version}_armhf_[b]l4t_r21[/b].deb libvisionworks-sfm-repo_{version}armhfl4t_r21.deb

TX1:
CUDA 7.0
libvisionworks-repo_{version}_armhf_[b]l4t_r23[/b].deb libvisionworks-sfm-repo_{version}armhfl4t_r23.deb

I’m not sure whether these components can be installed on Tango. However, from the context, looks like you installed CUDA 6.5, which is used for TK1, then tried to install VisionWorks with a version used for TX1. If this is the case, perhaps you can try to install the VisionWorks build for TK1.

Thanks for reply.
Indeed, I wanted to install tools for cross development. So I only tried to install visionworks
libvisionworks-repo_${version}amd64ubuntu14.04.deb

Should I have considered to install l4t version?
And I double checked that I only checked options for TK1 not for TX1. I was able to successfully install cuda 6.5. But when tackling visionworks, it says “depends on cuda 7” which is weird.

No, l4t version is to be installed on Jetson TK1 or TX1. There is a dependency issue here. On host, VisionWorks depends on CUDA 7. And CUDA 7 is shown when selecting TX1 in the dropdown list on top. We will fix the issue in next release. As a workaround, please install CUDA 7 on host before installing VisionWorks. Apologies for the inconvenience.

For what it’s worth, JetPack only sets up cross-compile environment for CUDA and GameWorks samples. It doesn’t try to setup cross-compile environment for VisionWorks, however.

Thanks for the clarification.
I was able to to install VisionWorks after installing CUDA 7.
Do you confirm that the current release of VisionWorks is going to work for TK1? Because TK1 does not support CUDA 7.

So there is no way to un-officially cross-compile for VisionWorks? Maybe by using CUDA cross development toolkit and statically linking against “libvisionworks.so”? Or different “libvisionworks.so” has to be presented for cross development?
Thanks

I haven’t found any document on setting up cross-compile environment for VisionWorks. Not sure whether there is any way to make it work.