Trying to get SPI2 working on Jetson NANO Production Module

I made many tests now.

Devkit 4.6.4 using jetson-io
→ working.
EMMC 4.6.4 using jetson-io
→ jetson-io not working. Manually applying device tree changes did not have effect on spi register, so did not work. (I did not find out, why) BUT using compiled dtb from this thread About using spi on Jetson NANO - #69 by ShaneCCC
did work. I could not figure out what was different to mine, but there are many “diffs” but around spi it seems very similar.
EMMC 4.5 is the actual version I need.
→ I tried resetted dts to original nvidia. Then I applied the spi pinmux and gpio changes again. Pinmux changes do take effect, but spi_test is still not working. I tried to flash compiled dtb from above thread, but flashing device tree fails, because of the version missmatch I guess.
Is there any chance, you can provide me with such device tree for Jetpack 4.5? Or maybe even better: how to reproduce this device tree from original sources, since it seems doing something really good.

Thanks for your help so far!