Trying to install CUDA toolkit for use on GTX 1650 on Ubuntu 18.04

The GTX 1650 was only recognized by the latest driver version 430.09. However, the latest version of the CUDA toolkit is sudo sh cuda_10.1.105_418.39_linux.run which is version 418.39. Is there a way to use the 418.39 driver, or do I need to wait for an updated toolkit?

Use the 430.09 driver.

That CUDA .run file will give you some options to select what gets installed. Deselect the option to install the bundled driver. Keep your 430.09 driver. it will work with that toolkit.

Hello,

I have a DELL XPS 15 7590 w GTX 1650 on it - UBUNTU 16.04 LTS with Win 10 dual boot.
I need to have CUDA installed which can detect the GPU - I have tried instructions from http://ubuntuhandbook.org/index.php/2019/04/nvidia-430-09-gtx-1650-support/
That failed every time and had to reinstall Ubuntu 16.04 (need that version for my codes to run).
I have tried getting the 430 driver from https://www.nvidia.com/download/driverResults.aspx/146189/en-us

I have specifically ordered this machine w the GTX 1650 for my computations, but failed thus far.
Still unable to detect the GPU - can you please advise?

Thanks,
Agni.

Hi,

Same problem as Agni. I have this computer https://www.pccomponentes.com/asus-rog-strix-g531gt-bq012-intel-core-i7-9750h-16gb-512gb-ssd-gtx1650-156?__cn_tracker=5d7396c373a63e49dbfb572d with Kubuntu 18.04.3 LTS.

I have tried to install the appropiate drivers GTX 1650 to then install CUDA, but that failed also and I had to reinstall Kubuntu. Is it possible to install CUDA in this GPU card?

Thanks,

Raül

CUDA toolkit 10.1 update 2 was successfully installed on my laptop (Ubuntu 18.04.3, kernel 5.0.0-29)

https://i.ibb.co/p1ZGnVk/cuda.png

  1. Install 430 driver http://ubuntuhandbook.org/index.php/2019/04/nvidia-430-09-gtx-1650-support/

  2. Just follow this guide https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

I my case, I downloaded the .deb file then install by running:

[i]sudo dpkg -i cuda-repo-ubuntu1804-10-1-local-10.1.243-418.87.00_1.0-1_amd64.deb
sudo apt-key add /var/cuda-repo-10-1-local-10.1.243-418.87.00_1.0-1/7fa2af80.pub
sudo apt update
sudo apt install cuda-toolkit-10-1 [/i]

These commands installs all CUDA Toolkit packages required to develop CUDA applications. Does not include the driver. If you running sudo apt install cuda , the 430 driver will be replaced by 418 driver, which does not support gtx 1650 --> failed to install cuda toolkit.

I have ubuntu 18.04, an nvidia 1650 and wanted to use tensorflow-gpu. What version of the nvidia driver, cuda and cudnn do I have to use?
Thank you