Trying to make samples after what I think is a successful installation.

Installing the sample from the 5.5 download. I am using a mac, os is 10.8.5. I have followed the CUDA_Getting_Started_Mac.pdf to install cuds. When I run kexstat | grep -i cuds I get,

117 0 0xffffff7f81a99000 0x2000 0x2000 com.nvidia.CUDA (1.1.0) <4 1>

moving on to 2.5.2 compiling the examples section and running the command mvcc -V if get

nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2013 NVIDIA Corporation
Built on Wed_Jul_10_11:16:01_PDT_2013
Cuda compilation tools, release 5.5, V5.5.0

I then try to make the sample programs using the make command in the directory where I installed the samples using the install script.

I tried sudo make and make, I received the following back:

/Developer/NVIDIA/CUDA-5.5/bin/nvcc -ccbin g++ -I…/…/common/inc -m64 -Xcompiler -arch -Xcompiler x86_64 -gencode arch=compute_10,code=sm_10 -gencode arch=compute_20,code=sm_20 -gencode arch=compute_30,code=sm_30 -gencode arch=compute_35,code=“sm_35,compute_35” -o asyncAPI.o -c asyncAPI.cu
clang: error: unsupported option ‘-dumpspecs’
clang: error: no input files
make[1]: *** [asyncAPI.o] Error 1
make: *** [0_Simple/asyncAPI/Makefile.ph_build] Error 2

I examined the findcudalib.mk in the directory containing asyncAPI and found at the end of the file


else

This would be the Mac OS X path if we had to do anything special

endif

It seems to me something is missing. There is nothing if that else section other than the comment.

Anyway, well, it’s probably me, what am I doing wrong?

Thanks everyone.

gg.