Trying to reflash jetson nano 2gb - Ubuntu goes into read-only mode

I’m trying to reflash a Jetson Nano 2GB that I have - it would get stuck booting and when plugged into a monitor would remain stuck on the Nvidia Logo, and I’ve already made sure the issue is not the image on the SD card because another Jetson is able to boot just fine from it.

I’ve been trying to follow this set of instructions I found, however eventually it reaches a point of putting my Ubuntu system into read-only mode. The first time this happened was during the actual flashing of the board, when that happened I decided to start the process over, and then it happened again a second time while extracting the sample filesystem.

For some context to the setup, I’m running my Ubuntu system in VirtualBox on a windows 10 computer, however the entire ubuntu system is saved to an external drive.

I saw somewhere someone said to check to make sure that the drive is “ext4”. The external drive itself is formatted as an NTFS, but when doing df -T file/location/here/ it says it’s ext4. So I’m unsure if this could be the issue or not

Beyond that I’m just kind of unsure what the issue could be


have you tried something like this to fix the read-only issue?

However; in general, we do not support flashing Jetson devices on VMes, and users have to work it out on their own when getting into trouble.

Oh yes I was able to fix it being in read only by running fsck and rebooting. It’s just that when it becomes read-only it then fails the remainder of everything it was doing because it’s in read-only.


then I would suggest delete the VM you currently use and get another VM image installed, or just run the whole process on a real Ubuntu PC, as it should be more stable.

Tried a new VM… seemed to be going alright until during the flashing process it hit this point

[ 0.4672 ] Boot Rom communication
[ 0.4696 ] tegrarcm --chip 0x21 0 --rcm rcm rcm_list_signed.xml
[ 0.4707 ] BootRom is not running
[ 0.5510 ]
[ 0.5511 ] Sending BCTs
[ 0.5536 ] tegrarcm --download bct P3448_A00_lpddr4_204Mhz_P987.bct

Where it then just completely stops - no errors just stops. I’ve tried leaving it awhile and restarting it but it keeps hitting a dead end here.

If I had access to a native Ubuntu PC I would try it, however that’s not the case


the reason why we do not support flashing using a VM is that the device will be connected and disconnected multiple times throughout the process of flashing, which may not be handled correctly by a VM, and it’s very likely in your case.

I think you may dual-boot your Windows PC to get an Ubuntu system, or see if Live USB works:
Trying to install JetPack using live ubuntu - Jetson & Embedded Systems / Jetson TK1 - NVIDIA Developer Forums

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.