Trying to run sample stereo_dummy on nano using the deploy.sh per the beginer instructions and it gets stuck

Here is what I am running and what it is doing. Any help appreciated.
kirk@Isaac:~/isaac-sdk/sdk$ ./…/engine/engine/build/deploy.sh --remote_user kirk -p //apps/samples/stereo_dummy:stereo_dummy-pkg -d jetpack44 -h 10.0.0.2
Loading:
Loading: 0 packages loaded
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)

I updated to the latest jetpack using sdk manager.
Here is what it says when I ctrl C out of it.
Analyzing: target //apps/samples/stereo_dummy:stereo_dummy-pkg (0 packages loaded, 0 targets configured)
^C
Bazel caught interrupt signal; shutting down.

kirk@Isaac:~/isaac-sdk/sdk$ INFO: Repository cuda_aarch64_jetpack44 instantiated at:
no stack (–record_rule_instantiation_callstack not enabled)
Repository rule http_archive defined at:
/home/kirk/.cache/bazel/_bazel_kirk/97b193624b70decb20aaf0a920e33896/external/bazel_tools/tools/build_defs/repo/http.bzl:336:16: in
ERROR: An error occurred during the fetch of repository ‘cuda_aarch64_jetpack44’:
java.io.IOException: thread interrupted
ERROR: build interrupted
INFO: Elapsed time: 978.344s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (0 packages loaded, 0 targets configured)
FAILED: Build did NOT complete successfully (0 packages loaded, 0 targets configured)

kirk@Isaac:~/isaac-sdk/sdk$

It was downloading the cuda, tool along time, found it by looking at gnome-system and saw the downloaing.
It ran, deployed and worked. One error as I updated to latest jetpack

ERROR external/com_nvidia_isaac_engine/engine/alice/components/Codelet.cpp@229: Component ‘_check_operating_system/isaac.alice.CheckOperatingSystem’ of type ‘isaac::alice::CheckOperatingSystem’ reported FAILURE:

'/etc/nv_tegra_release' does not start with '# R32 (release), REVISION: 4.4'. Please flash L4T using Jetpack 4.4.1.

IIRC Isaac does not support the latest jetpack.
You specifically need to flash Jetpack 4.4.1 or Isaac will refuse to launch.*

*that or hack /etc/nv_tegra_release to report that its the old version and hope for the best. I wouldn’t recommend this latter approach if you can avoid it.