Turn off deinterlacing on Jetson TK1

I am doing decoding and encoding at the same time using Jatson TK1 board to process videos. However, there seems to be an automatic deinterlacing thread, which I do not really want it. I would actually like my stream to be interlaced. I have tried to put ! deinterlace mode=2 ! inside of the pipeline, but it didn’t help. Because of the auto deinterlacing, my stream is losing a lot of its original image quality as well (pixelized curve).

Sample code:
gst-launch-0.10 udpsrc port=5050 ! tsdemux name=demux demux.video_0200 ! queue ! nv_omx_h264dec ! queue !
nv_omx_h264enc ! video/x-h264 ! mux. mpegtsmux name=mux m2ts-mode=false pat-interval=3000 pmt-interval=3000 ! rtpmp2tpay pt=33 ! udpsink port=5005 host= sync=true enable-last-buffer=true -v

While running this, the console will always tell me that:
TVMR: TVMRInit: 89: deinterlaceType = 0
TVMR: cbBeginSequence: 1028: NumOfSurfaces = 4, InteraceStream = 1, InterlaceEnabled = 1, bSecure = 0, MVC = 0 Semiplanar = 1, bReinit = 1
Allocating new output: 1920x1088 (x 6), ThumbnailMode = 0
TVMR: DeinterlaceThread: 696: DeinterlaceThread is created

Is there any way to turn this deinterlace off? Thanks.

Hi littlecounter,
It looks like you got no response :-(
Can you tell me how to switch Interlace support on? e.g. InterlaceEnabled = 1