TwinView does not disable using 3xx.xx drivers

So here’s a strange problem. If two monitors are connected to one GPU and we wanted to disable the secondary display we would normally set

option “TwinView” “false”

This worked fine for all drivers below 3xx.xx. We have recently upgraded to 319.23 and now if we have

option “TwinView” “false”

this is ignored and both screens act as if TwinView is enabled.

Upon opening the nvidia control panel it says TwinView is enabled despite being set to “false” in the xorg.conf.

The way we have got round this it is to change:

Option “MetaModes” “nvidia-auto-select, nvidia-auto-select”


Option “MetaModes” “nvidia-auto-select”

This is fine for us but why does

option “TwinView” “false”

get ignored?



The TwinView option was removed because the behavior it configured is always on now. You can control which display devices are used when the server starts as you did through the MetaModes option, or by specifying the one(s) you want with the UseDisplayDevice option.