Two cameras on Production Module without I2C HUB

Hello,

I’m trying to run two IMX477 cameras on custom board without I2C Mux. I tried removing definitions about
i2cmux, but then module wouldn’t boot.
I checked NANO multi CSI without I2C HUB, but the solution seems not to apply for my problem.

	i2c@7000c400 {
		#address-cells = <0x1>;
		#size-cells = <0x0>;
		compatible = "nvidia,tegra210-i2c";
		reg = <0x0 0x7000c400 0x0 0x100>;
		interrupts = <0x0 0x54 0x4>;
		iommus = <0x30 0xe>;
		status = "okay";
		clock-frequency = <0x186a0>;
		dmas = <0x51 0x16 0x51 0x16>;
		dma-names = "rx", "tx";
		clocks = <0x26 0x36 0x26 0xf3>;
		clock-names = "div-clk", "parent";
		resets = <0x26 0x36>;
		reset-names = "i2c";
		linux,phandle = <0x10e>;
		phandle = <0x10e>;

		prod-settings {

			prod_c_sm {
				prod = <0x94 0xffffffff 0x304 0x6c 0xffffffff 0x160001>;
			};
		};

		i2cmux@70 {
			compatible = "nxp,pca9546";
			reg = <0x70>;
			#address-cells = <0x1>;
			#size-cells = <0x0>;
			vcc-supply = <0x4c>;
			vcc-pullup-supply = <0x4c>;
			status = "disabled";
			linux,phandle = <0xbe>;
			phandle = <0xbe>;

			i2c@0 {
				reg = <0x0>;
				i2c-mux,deselect-on-exit;
				#address-cells = <0x1>;
				#size-cells = <0x0>;
			};

			i2c@1 {
				reg = <0x1>;
				i2c-mux,deselect-on-exit;
				#address-cells = <0x1>;
				#size-cells = <0x0>;

				ina3221x@40 {
					compatible = "ti,ina3221x";
					reg = <0x40>;
					ti,trigger-config = <0x7003>;
					ti,continuous-config = <0x7c07>;
					ti,enable-forced-continuous;
					#address-cells = <0x1>;
					#size-cells = <0x0>;

					channel@0 {
						reg = <0x0>;
						ti,rail-name = "VDD_5V";
						ti,shunt-resistor-mohm = <0xa>;
					};

					channel@1 {
						reg = <0x1>;
						ti,rail-name = "VDD_3V3";
						ti,shunt-resistor-mohm = <0xa>;
					};

					channel@2 {
						reg = <0x2>;
						ti,rail-name = "VDD_1V8";
						ti,shunt-resistor-mohm = <0x1>;
					};
				};

tegra210-p3448-0002-p3449-0000-b00-user-custom.txt (324.9 KB)

Thanks

I would suggest remove all of the sensor dts file and only include the imx477 to modify it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.