Two GTX280 on P45, Fedora Core9, cannot start X-windows lack of driver of GTX280 or P45?

Hi,

I’ve installed two GTX280 on a P45 with Q6600, after installing Fedora Core9 (32 bit), and installed the up-to-date Linux driver (version 177.73), I cannot start x-window. and it tells me: no devices detected.

Anyone has the similar experience?

Thanks,
Dehao

did you modify /etc/X11/xorg.conf?

This problem is solve by using nvidia-xconfig to enable multigpu

Hi danielcdh! Could you please tell us about your hardware system?

I am having a similar issue. I just downloaded the latest driver 180.06 and tried to install.

The steps that I used to install are as follows:

  1. Ctrl+Alt+F2, then logged in as root.
  2. init 3 to bring down X
  3. executed the NVIDIA driver which also did the setup up for nvidia-xconfig
  4. tried init 5 to bring X back up, but no luck.

I tried a reboot, but it just comes back to the command line login. I tried replacing the xorg.conf, but that didn’t work either.

System setup:

Fedora 9, (2) 8800gts

Well after taking a look at the nvidia-xconfig man page I found a “-a” option which activates all gpus.

So I executed:

nvidia-xconfig -a

then

“init 5” to start X and it seemed to work.

I’ll just take the second gtx off your hands so you can enjoy yourself!

wow… it works! (this is my first post on this forum and I thought it will be a :thumbsdown: ) thank you meb_4444 !!!

FYI, I’m assembling a cuda system for astro-type scientific applications. my ambition is to port some serious hydrocodes and develop a lot of custom-made particle codes.

I need to install cuda examples to put my 2 gtx280 under heavy load and see how my Zalman water coolong (LQ1000 case with included radiator, very nice) holds up with 1 quad-core intel cpu and 2 BFG cards.

theoretically 2 cards exhaust the cooling specifications (500W of heat) Zalman told me on the phone, but I think sufficient heat may go into the air instead of my water coolant, so maybe I can install the 3rd card.

on the other hand, that one would certainly be restricted to x8 PCIe. right now I don’t know whether that’s a bottleneck for my applications. Do you guys often experience PICe bandwidth as a bottleneck?

…forgot to add a plea to NVIDIA: please fix the driver installer, if possible, so that correct xorg.conf is produced automatically for multiple GPUs.

I think you must have been unlucky, since I have been having more than 1 card in my PC for >1 year, and never had this problem before.

2x 8800GTX

8800GTX + C1060

Quadro FX 4800 + C1060

This all in FC8. I install the driver, and then as root run nvidia-… enable (forgot the exact command, have to look at work)

You can try it yourself by pushing TAB after nvidia, you see a few options, I believe it is the only one that makes sense apart from nvidia-xconfig

Hi Denis,
thanks, but upon checking - I don’t have anything useful among nvidia-* in my F10 distro.
It’s not fun to have an official driver installation produce incomplete configuration files that hang X windows, under any circumstances…
primary card should absolutely be activated (say, PCI slot with lowest #) and imho all the other gpus too.

nvidia-settings is the program I was talking about.

I haven’t tried FC10 yet, maybe that is the difference.

ok, thnx.

I’m glad to say that the dual-card system worked well - the beta driver 180.16 works well for me.

I compiled and run almost all test problems successfully, including the dual GPU test.

The bandwith test went better than expected, 5.4 GBps to and 5.2 BGps from gpu0. Actually, isn’t it better than the PCIe 2.0 spec?

I’m now doing something questionable, but I want to push this project to the limit: inserting the third gtx280 card and trying to see if the cooling system can handle it, and measuring the bandwidth of the second and third card. this will take me a while, since the plumming for 2 cards is way simpler than for 3 cards, at least using those incredibly short barbs from BFG.

I sprung a leak immediately :-|

pawel