TX-1 Slow Performance and Program Errors Following Reinstall of Jetpack

Hello,
I recently did a fresh install on my TX-1 that formerly worked great. After reinstalling Jetpack, I installed the ZED SDK and things have gone south on several fronts:

  1. Many programs no longer work for a variety of reasons e.g. Firefox, Cheese.

  2. The program issues seem to focus around vision systems. Take the 3 examples:

A) Cheese gives the following error: One of more needed GStreamer elements are missing: cluttervideosink
FYI: I spent a couple of hours searching forums on this cheese error and none of the items worked

B) An OpenCV program I wrote (that worked previously on this unit), now gives the error:
HIGHGUI ERROR: V4L/V$L2: VIDIOC_CROPCAP
select timeout
select timeout
Segmentation fault

C) I am unable to run any of the ZED executables in the tools directory (e.g. ubuntu@tegra-ubuntu:/usr/local/zed/tools$ ./ZED\ Explorer
bash: ./ZED Explorer: No such file or directory_ )

More info is below.

  1. Performance is markedly slower than before

With the plethora of problems here, I hope someone with much more experience would notice the common thread - your help is much appreciated!

Best Regards,

ubuntu@tegra-ubuntu:/usr/local/zed/tools$ ls -la
total 68020
drwx------ 3 ubuntu ubuntu 4096 Aug 4 20:30 .
drwx------ 8 ubuntu root 4096 Aug 4 20:31 …
drwx------ 3 ubuntu ubuntu 4096 Aug 4 20:30 lib
-rw------- 1 ubuntu ubuntu 39 Aug 4 22:35 qt.conf
-rwx------ 1 ubuntu ubuntu 16388551 Aug 4 22:35 ZED Depth Viewer
-rwx------ 1 ubuntu ubuntu 14550902 Aug 4 22:35 ZED Explorer
-rwx------ 1 ubuntu ubuntu 14848356 Aug 4 22:35 ZED InstallChecker
-rwx------ 1 ubuntu ubuntu 14263528 Aug 4 22:35 ZED Settings App
-rwx------ 1 ubuntu ubuntu 9569142 Aug 4 22:35 ZED SVOEditor
ubuntu@tegra-ubuntu:/usr/local/zed/tools$ ./ZED\ Explorer
bash: ./ZED Explorer: No such file or directory
ubuntu@tegra-ubuntu:/usr/local/zed/tools$

Is this version of L4T the same as before? Were they flashed using the same commands? Especially, was sudo used where required? Even with R24.1 there are two different sample rootfs environments which will behave differently. R23.2 is probably the environment which existed when the Zed software was first built. All of them will behave wrong if for example a sample rootfs was unpacked without root authority.

It is presumably the same version of L4T. I am unsure if they were flashed with the same commands as someone else who no longer works with me did the initial install.

It seems the best move is to wipe the unit and start afresh - is there a process for doing that, as the dev kit came with an OS on it?

Thank you!

Flash is fairly easy if you just want to flash. If you are interested in all of the other packages, such as CUDA and OpenCV, it gets a bit more complicated. JetPack bundles it all together to try to simplify it, although it is possible this can also complicate things, as it requires your host to be Ubuntu 14. For simple flash, any x86_64 Linux works (I use Fedora).

The Jetson arrives with 64-bit kernel and 32-bit user space. This is fairly well tested. For this you’d flash R23.2. For 64-bit kernel and 64-bit user space, you’d flash R24.1 with the 64-bit sample rootfs. This is fairly new and has more issues.

In all cases simple flash is with driver package plus sample rootfs. JetPack makes several versions available and things like CUDA, not just flash…so probably go to one of these URLs and get the appropriate R23.2 or R24.1 driver+sample rootfs, or else indirectly via JetPack. See:
https://developer.nvidia.com/embedded/linux-tegra
https://developer.nvidia.com/embedded/linux-tegra-r232

If you were to use just driver plus sample rootfs, it goes something like this:
Unpack driver package.

Within the rootfs subdirectory of driver package, unpack sample rootfs using "sudo" so root permissions work.
cd back up one directory from rootfs, find "apply_binaries.sh".
sudo apply_binaries.sh
Make sure Jetson has micro-B USB cable connected and is in recovery mode (hold down recovery button and power up...either tap power if off, or tap reset if already on).
sudo ./flash.sh -S 14580MiB jetson-tx1 mmcblk0p1
# ...expect to wait a long time, over an hour, and to consume perhaps 20GB of disk space on the host.

If you use JetPack it comes with other directions. One is that flash still uses the micro-B USB cable in recovery mode, the other is that the extra packages require ethernet cable connected to host or router.

NOTE: You can do simple install and run JetPack at any later date for other packages.

Yes, for my application I will need OpenCV-Tegra, CUDA and the ZED SDK. I spoke with the ZED folks and they said I need to roll back to Jetpack 2.1 (as there are some bugs with the ZED SDK with regard to 2.2).

We have plenty of available hosts with Ubuntu 14.04 so no worries there. Based on what you and the ZED folks are saying, it seems the steps are to:

  1. Flash with R23.2: https://developer.nvidia.com/embedded/linux-tegra-r232
  2. Install Jet Pack 2.1: https://developer.nvidia.com/embedded/jetpack-2_1

Am I smoking crack or does that sound correct? Could you please tell me the proper procedure to do that?

Best Regards,

JetPack itself can install to a host, and is never directly part of the Jetson itself. Indirectly, if you find it convenient, JetPack will flash the Jetson. JetPack can also manage install of many packages on a Jetson without doing a flash…think of it as a front end to the native package manager with regard to Jetson-specific and nVidia-specific packages (I qualify as not just jetson because some of those packages can be installed to the host as well).

If a native Ubuntu 14 desktop host is available, you might as well just let JetPack do both flash and extra package install. Stage 1 will use the USB cable for flash (behind the scenes JetPack will operate the driver package+sample rootfs), you ignore the reboot now message, Jetson will reboot itself, and then stage 2 uses the ethernet cable to install your package selections. The great part about that is it will set up network and you won’t worry about package install order or download details.

Got it - apologies for the lull in comms.

I was able to flash the device successfully and the device is operating properly with regard to speed and operability.

But when I get to the step 14 of the manual: http://docs.nvidia.com/jetpack-l4t/2_1/index.html#developertools/mobile/jetpack/jetpack_l4t/2.1/jetpack_l4t_install.htm

It cannot determine IP address of target. I’ve checked other forums (e.g. https://devtalk.nvidia.com/default/topic/898683/jetpack-2-0-on-jetson-tk1-installation-doesn-t-finish/?offset=24 ) but I am not sure where to start. I’ve tried various methods of step 10 to no avail. Prior, I selected “Device access Internet via router/ switch” and then selected Eth0 on the next step and it worked fine. I have both device wirelessly connected to internet and an ethernet cable connecting the two.

What do you think the best next step is?

Thank you!

It sounds like it installed correctly. To determine address directly from the Jetson (such as console login or GUI login or serial console) use “ifconfig eth0”. Otherwise the router assigning the address will know the address…e.g., most routers have a web access where you can see what addresses were assigned.

Thanks so much - this did the trick! I had to connect the two devices with a switch - much appreciated.