TX1 cann't export GPIO_EXP0_INT as GPIO

I use Jeckpack3.1, I want to export GPIO_EXP0_INT as GPIO.But fialed
It report “echo: write error: Device or resource busy”

hello Echo1900,

could you share the steps/commands you would like to export GPIO_EXP0_INT as GPIO.
thanks

sudo chmod 777 -R /sys/class/gpio/*
sudo echo 201 > /sys/class/gpio/export

Hello Echo1900 ,

i have too , with a Tegra L4T from “tegra210-jetson-cv-base-p2597-2180-a00.dtb” (flash recovery) :

root@tegra-ubuntu:/# sudo echo 201 > /sys/class/gpio/export
echo: write error: Device or resource busy

and i checked the gpio list :

root@tegra-ubuntu:/# cat /sys/kernel/debug/gpio 
GPIOs 0-255, platform/6000d000.gpio, tegra-gpio:
 gpio-2   (                    |pcie_wake           ) in  hi    
 gpio-56  (                    |wlan_pwr            ) out hi    
 gpio-57  (                    |rtl-5v0             ) out hi    
 gpio-58  (                    |wlan-default-input-h) in  lo IRQ
 gpio-59  (                    |bt_ext_wake         ) out hi    
 gpio-60  (                    |reset_gpio          ) out lo    
 gpio-61  (                    |bt_host_wake        ) in  lo IRQ
 gpio-64  (                    |wlan-default-output-) out hi    
 gpio-65  (                    |wlan-default-input-i) in  hi    
 gpio-67  (                    |vdd-disp-3v0        ) out lo    
 gpio-148 (                    |en-vdd-vcm-2v8      ) out lo    
 gpio-149 (                    |cam1-rst            ) out lo    
 gpio-151 (                    |cam0-pwdn           ) out lo    
 gpio-152 (                    |cam1-pwdn           ) out lo    
 gpio-169 (                    |lcd-bl-en           ) out lo    
 gpio-188 (                    |temp_alert          ) in  hi IRQ
 gpio-189 (                    |Power               ) in  hi IRQ
 gpio-190 (                    |Volume Up           ) in  hi IRQ
 gpio-192 (                    |Volume Down         ) in  hi IRQ
 gpio-200 (                    |extcon:extcon@1     ) in  lo IRQ
 gpio-201 (                    |cd                  ) in  hi IRQ
 gpio-203 (                    |en-vdd-sd           ) out lo    
 gpio-204 (                    |wp                  ) in  lo    
 gpio-225 (                    |hdmi2.0_hpd         ) in  lo IRQ
 gpio-228 (                    |usb-vbus1           ) in  hi    
 gpio-229 (                    |en-usb-vbus2        ) in  hi    

GPIOs 504-511, platform/max77620-gpio, max77620-gpio, can sleep:
 gpio-504 (                    |extcon:extcon@1     ) in  lo    
 gpio-505 (                    |vdd-sys-boost       ) out hi    
 gpio-506 (                    |spmic-default-output) out hi    
 gpio-507 (                    |vdd-3v3             ) out hi    
 gpio-510 (                    |enable              ) out lo    
 gpio-511 (                    |max77620-gpio7      ) out lo

The output list will show you the current list og reserved GPIO.

I think you can use DTS(i) for declare and use this GPIO (201).

Did you find an issu ? can you access to DTS/kernel git for 28.1 ?

Not yet, I changed DTB file,no use.

I haven’t looked at the specific issue, but if you are using R28.1 you might need to change procedure for DTB edits versus earlier releases. To verify if your changes truly went in you can create a DTS file from “/proc” and know this is what the system is actually using:

dtc -I fs -O dts -o extracted.dts /proc/device-tree

In another post , https://devtalk.nvidia.com/default/topic/1023920/bring-up-another-usb3-0-usb_ss-2-on-tx1-l4t-r28-1/#5209531 , Nvidia team talk about problems : they work on update docs.

But, we try to download source from source_sync.sh with r28.1 ( JetPack 3.1) , but … i have too TIMEOUT error … firewall or not ?! … --’

Like Echo1900 , i try to used GPIO without source, without docs … tiny hot !!!

At time , i try a J120 board , the TX1 was downgrade on 24.2.1 ( jetpack 30.1) … that’s ok for 2x USB3 !!! now i try to use GPIO … without J120 sources … ^^’

A waste of time … And the day where we could be use Cuda, Deep learning & Co is faraway … :/

source_sync.sh works for me, but it seems failures may depend on where you are in the world (I’m central US). In other cases (at least in the past) there have been issues with directories having a space in the name, as well as perhaps non-UTF8 character sets…I don’t know what your case is, but if you could give more info on how it fails it might aid debugging.

One thing I saw long ago helped with download issues under JetPack is to run single threaded:

NV_DEVTOOLS_FORBID_MULTIPLE_DOWNLOAD_THREADS=1 ./JetPack-L4T-2.1-linux-x64.run

The CUDA and such are in JetPack. I don’t know of an alternative for that, although you can extract URLs from intermediate files and use wget without requiring JetPack. Basically “bash ./JetPack-L4T-2.3.1-linux-x64.run --noexec” generates intermediate files and then running “./Chooser” creates “repository.json”. It is repository.json which contains useful URLs.

I do not have a J120 so I don’t know what might be required to deal with that.

Hi,

from France, with UTF8 under Lubuntu (16.04). you can check the english skill !!! ^^’

Asap, i try your single thread method !!!

NV_DEVTOOLS_FORBID_MULTIPLE_DOWNLOAD_THREADS = 1 ./JetPack-L4T-2.1-linux-x64.run

we wait a Auvidea update for the r28.1. But, i can test a TX1 with repository.json method for testing a DTS / kernels.

of course, we doesn’t have J120 source … may be Auvidea can share that