TX1 doesn't boot up

I am having two TX1 board.
And both TX1 module is having R24.2.1.

During some development testing, One TX1 module freezes and supply LED CR1, CR2 suddenly off at the time of booting.
Below is the last valid logs

...
...
[    1.074317] vdd-3v3: 3300 mV ; Rail ON
[    1.078058] max77620-gpio7: 1050 mV ; Rail ON
[    1.081306] max77620-gpio7: supplied by vdd-gen-pll-edp
[    1.086660] lcd-bl-en: 1800 mV ; Rail ON
[    1.090537] en-vdd-sd: 3300 mV ; Rail OFF
[    1.094385] en-vdd-sd: supplied by vdd-3v3
[    1.098526] reg-fixed-sync-voltage 5.regulator: Consumer c1 does not have device name
[    1.106711] en-vdd-cam: 1800 mV ; Rail ON
[    1.110267] reg-fixed-sync-voltage 5.regulator: Failed to find supply vin
[    1.117026] reg-fixed-sync-voltage 5.regulator: Failed to register regulator: -517
[    1.124527] platform 5.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[    1.139092] vdd-sys-boost: 5000 mV ; Rail ON
[    1.141802] vdd-hdmi: 5000 mV ; Rail OFF
[    1.145297] vdd-hdmi: supplied by vdd-3v3
[    1.149405] aux-3v3: 3300 mV ; Rail ON
[    1.153126] snsr_pm: 3300 mV ; Rail ON
[    1.157327] vdd-disp-3v0: 3000 mV ; Rail ON
[    1.161310] vdd-fan: 5000 mV ; Rail OFF
[    1.164839] usb-vbus1: 5000 mV ; Rail OFF
[    1.168697] usb-vbus1: supplied by vdd-3v3
[    1.172926] usb-vbus3: 5000 mV ; Rail OFF
[    1.176755] usb-vbus3: supplied by vdd-3v3
[    1.181247] en-vdd-ts-1v8: 1800 mV ; Rail OFF
[    1.185543] en-vdd-ts-hv-3v3: 3300 mV ; Rail OFF
[    1.185543] en-vdd-ts-hv-3v3: 3300 mV ; Rail OFF
[    1.190288] en-vdd-disp-3v3: 3300 mV ; Rail ON
*��mdm-pwr-3v7: ; Rail OFF
[    1�ltage ce.regulator: Consumer c0 does not have device na

During the hardware check, I find vdd_1v8 found short with GND.
I tried to reset power and restart but there was no log on UART and no CR1, CR2 LEDs. But 5V & 3.3V supply seems ok.

I replaced U9. Now there is no shorting between 1.8v to GND. And now tried to start TX1. This time Both CR1, CR2 LEDs light up and 1.8V appears OK. But Same NO UART log and TX1 not booting UP.

But if I place the same module to another TX1 kit it powers up successfully.
So, I think there is something wrong with my first TX1 kit board.

I checked all the power section it seems OK to me.
Please guide me to make my faulty TX1 kit comes alive…!!!

Please check if the module board could enter recovery mode, Try to re-flash image if recovery mode works.

I think the Module is OK. This is working on another Kit. And also I can reflash it.
I think there’s some wrong in the kit.

I was using tegra210-jetson-cv-p2597-2180-a00-auo-1080p-edp.dtb and AUO 10.1 eDP panel.
Some hardware problem cause en-vdd-disp-1v8 to be overload and causes 1.8V to be short.
But after replacing U9, now there is no shorting. But then also this kit is not starting.
Due to no log on the UART, i was unable to debug which causes the problem.

Please check the power up sequence first as illustrated in figure 4 of OEM DG to locate the issue.

Thanks for your help.
Finally, my kit works after removing the U9. and giving 1.8V externally.