TX1 Minimum Turn-On Voltage

So I understand the voltage range (VIN) of the TX1 to be 5.5-19.6V. We have developed our own carrier board at this point and during the development process I noticed the SOM would NOT turn on unless the voltage was ~12.5V. To ensure in-rush current was not the problem for going any lower with voltage I used a battery and a very capable power supply but same result for both. Once the SOM was on I could lower the voltage with my variable supply and it would operate in the range that is specified just not turn on initially unless the voltage was greater that or equal to ~12.5V. This was the case whether I used the dev board or our carrier board the result was the same.

This was not really a problem for us since we are using a 4S lipo ultimately in our application and we monitor the voltage and turn off before the 12.5V.

All was good until we received a new batch of SOM’s today. Now it seems the minimum turn on voltage is like 17.1V! It is the same for our carrier board and when it is on the dev board.

Can someone tell me why this is the case?

Some people have talked about changing a capacitor to improve this (I’m not sure which one, and not all modules do this). On the ones where changing the capacitor would help you’d also find a couple of rapid “on” taps of the on switch would get boot to work…if that is true for you, then there might be a capacitor change required.

Hi snageli,

17.1V turn on voltage is abnormal, could you pls share the revision label of new SOM? Did you measure the voltage drop of 17.1V turning on?

So I am not sure of the revision label you are talking about but here are some markings for each:

SOM w/12.5V Turn-On (This one came with a dev kit)
S/N 0324415032086
699-82180-1000-100 K
P/N 135-0601-000 R4

SOM w/17.1V Turn-On (This one was purchased just as a SOM)
S/N 0322916110921
699-82180-1000-400 N
P/N 15-0657-000 R1

I will measure the voltage drop tonight and get it over to you


Was this a capacitor change on the carrier board or on the actual SOM?

I do not know the specifics of that capacitor change, but I do think it was on the carrier board, not the module. Someone would have to confirm that.

I have some oscilloscope plots of the main VIN to the SOM when powering it on. To me both the R1 and R4 SOM’s voltage signature looks very similar. The max drop in the voltage is ~40mV. The difference is the R4 will turn on at 12.5V and R1 17.1V.

If I lower the voltage and try to turn it on I do not see and voltage fluctuation on the main VIN as it is like it is not even trying to turn-on.

I attached the plots.

R1 17.4V Turn-On.BMP (76.1 KB)

R4 12.5V Turn-On.BMP (76.1 KB)

Have you tried the rapid double tap (or even more than double) of power on? This would be a temporary workaround, but more important, it would identify if it was the capacitor issue I saw.

Ya, I have done the rapid double tap. I have read about that on other threads but does not work here either.

That capacitor is then unlikely to be the problem. Something else must be going on.

It’s strange, never met this before.

Can you use more powerful oscilloscope to do this test?
What’s the max current of the power supply? Did you do any changes on the dev kit carrier board or SOM board?

Not sure what a more powerful scope would give me. The dev board is the same. The only difference is the revision on these SOM’s, I have made no mods to both but they act differently. Do you know the difference between a R1 and R4 SOM that would affect this?

The power supply I use is a variable 30V 3A supply. I can also use my 4S lipo battery but that will not turn on the R1 board since the output voltage is lower.

Sometimes a component attached to PCIe, USB, or SATA can cause issues as well. Other than your keyboard/mouse/monitor, what else might be attached? Admittedly, that isn’t a strong likelihood, but it has to be considered (especially USB3 devices drawing power from the bus).

Hi snageli,

Just checked our own -100 & -400 SOM, all can turn on w/ 4.99V~5.41V, seems this is a specific issue on your boards.

Did you attach some devices during power on as linuxdev said? If so you might need to remove all of them to check again. Also you might need to check the real voltage drop between VDD_IN and GND on board with multimeter instead of reading value from power supply.

I have disconnected all peripherals from USB, PCIe, eSATA, etc…

Just referencing the development carrier board provided by NVIDIA I am unable to get either the -100 or -400 SOM to power up any differently.

What were you using to “check” your -100 & -400 SOM, the development carrier board? I am surprised to see that you are mentioning 4.99V since the minimum is 5.5V. When I get the SOM to turn-on with higher voltages I can decrease the voltage with my variable supply and it will turn off around 5.5V so I have seen it operate down to the voltages published on the datasheet but just will simply not turn-on across the voltage range that is published.

Do you have a very large capacitor you could put across the power supply close to the connector? You might try putting that plus a smaller high quality capacitor (perhaps 1uF+ tantalum) very close to the connector. Then see if the turn on voltage changes…if the voltage required goes down, then you can isolate the issue to being power requirements instead of issues like component failure.

If this does not help it may be the connector itself providing too much resistance…some barrel connectors may actually introduce unexpected issues (the connector on the power supply end is probably something deemed “compatible”, but those connectors do have minor differences and one brand can do better than the other under higher loads). Bypassing the connector and soldering directly to the board would demonstrate this, although I doubt soldering to the board is a good idea.

Yes, checked w/ dev kit carrier board. It can be powered up in 4.99V w/ -410 board.

So did you check the Power Up Sequence of Figure 4 of OEM Design Guide?

And what’s your dev kit carrier board revision (numbers contain ‘2597’)?

I may have found a potential solution. Once I get it worked out I will provide details.

I can confirm that I see the same behavior when operating at 12V in all the boards I tried (5 or 6 TX1s) acquired at different points in time. Haven’t tried the capacitor change on the carrier board yet, as I only found out about that possible solution last week. Adding a capacitor in parallel to the input voltage connector makes sense, I’ll try it today and will report any changes.

EDIT: This happens even with no peripherals (hdmi,usb,sata,etc) connected to the board.

Hi NunoA,

What’s the result of adding a capacitor?

Did you check the Power Up Sequence of Figure 4 of OEM Design Guide?

And what’s your dev kit carrier board revision (numbers contain ‘2597’)?