Tx1 Robot ROS Configuration Setup Issues(Unable to sync device)

Hello, I have been having trouble setting up ROS for the TX1 with this kit:

when I run
source ~/.bashrc; source ~/catkin_ws/devel/setup.sh; roslaunch jet_bringup jet_real.launch

I get this error:

[ERROR] [1528699343.433569]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

Full Output:

p.sh; roslaunch jet_bringup jet_real.launch
... logging to /home/ubuntu/.ros/log/8d43f964-6d42-11e8-b06c-00044b6738e3/roslaunch-tegra-ubuntu-12575.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
xacro.py is deprecated; please use xacro instead
started roslaunch server


 * /jet_drive_controller/angular/z/has_acceleration_limits: False
 * /jet_drive_controller/angular/z/has_velocity_limits: False
 * /jet_drive_controller/base_frame_id: base_link
 * /jet_drive_controller/cmd_vel_timeout: 1.0
 * /jet_drive_controller/enable_odom_tf: True
 * /jet_drive_controller/left_wheel: left_wheel_joint
 * /jet_drive_controller/linear/x/has_acceleration_limits: False
 * /jet_drive_controller/linear/x/has_velocity_limits: False
 * /jet_drive_controller/pose_covariance_diagonal: [1e-05, 1e-05, 10...
 * /jet_drive_controller/publish_rate: 100
 * /jet_drive_controller/right_wheel: right_wheel_joint
 * /jet_drive_controller/twist_covariance_diagonal: [0.0, 0.0, 0.0, 0...
 * /jet_drive_controller/type: diff_drive_contro...
 * /jet_drive_controller/wheel_radius: 0.077
 * /jet_drive_controller/wheel_radius_multiplier: 1.0
 * /jet_drive_controller/wheel_separation: 0.36
 * /jet_drive_controller/wheel_separation_multiplier: 1.0
 * /joint_state_controller/publish_rate: 50
 * /joint_state_controller/type: joint_state_contr...
 * /joy_node/autorepeat_rate: 20
 * /joy_node/deadzone: 0.3
 * /joy_node/dev: /dev/input/js0
 * /robot_description: <?xml version="1....
 * /rosapi/params_glob: [*]
 * /rosapi/services_glob: [*]
 * /rosapi/topics_glob: [*]
 * /rosbridge_websocket/address: 
 * /rosbridge_websocket/authenticate: False
 * /rosbridge_websocket/bson_only_mode: False
 * /rosbridge_websocket/delay_between_messages: 0
 * /rosbridge_websocket/fragment_timeout: 600
 * /rosbridge_websocket/max_message_size: None
 * /rosbridge_websocket/params_glob: [*]
 * /rosbridge_websocket/port: 9090
 * /rosbridge_websocket/retry_startup_delay: 5
 * /rosbridge_websocket/services_glob: [*]
 * /rosbridge_websocket/topics_glob: [*]
 * /rosbridge_websocket/unregister_timeout: 10
 * /rosdistro: kinetic
 * /rosversion: 1.12.13
 * /serial_node/baud: 115200
 * /serial_node/port: /dev/ttyACM0
 * /teleop_twist_joy/axis_angular: 4
 * /teleop_twist_joy/axis_linear: 5
 * /teleop_twist_joy/scale_angular: 1
 * /teleop_twist_joy/scale_linear: 1
 * /usb_cam/camera_frame_id: usb_cam
 * /usb_cam/image_height: 240
 * /usb_cam/image_width: 320
 * /usb_cam/io_method: mmap
 * /usb_cam/pixel_format: yuyv
 * /usb_cam/video_device: /dev/video1

    cmdvelrelay (topic_tools/relay)
    controller_spawner (controller_manager/spawner)
    jet_driver_node (jet_driver/jet_driver_node)
    joy_node (joy/joy_node)
    odomrelay (topic_tools/relay)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    rosapi (rosapi/rosapi_node)
    rosbridge_websocket (rosbridge_server/rosbridge_websocket)
    serial_node (rosserial_python/serial_node.py)
    teleop_twist_joy (teleop_twist_joy/teleop_node)
    usb_cam (usb_cam/usb_cam_node)

auto-starting new master
process[master]: started with pid [12588]

setting /run_id to 8d43f964-6d42-11e8-b06c-00044b6738e3
process[rosout-1]: started with pid [12601]
started core service [/rosout]
process[rosbridge_websocket-2]: started with pid [12618]
process[rosapi-3]: started with pid [12619]
process[serial_node-4]: started with pid [12620]
process[joy_node-5]: started with pid [12621]
process[teleop_twist_joy-6]: started with pid [12622]
process[usb_cam-7]: started with pid [12624]
process[controller_spawner-8]: started with pid [12635]
process[robot_state_publisher-9]: started with pid [12644]
process[cmdvelrelay-10]: started with pid [12650]
process[odomrelay-11]: started with pid [12653]
process[jet_driver_node-12]: started with pid [12655]
[ERROR] [1528699326.101000877]: Couldn't open joystick /dev/input/js0. Will retry every second.
[ INFO] [1528699326.159774728]: velocity multiplier: 10.000000
registered capabilities (classes):
 - rosbridge_library.capabilities.call_service.CallService
 - rosbridge_library.capabilities.advertise.Advertise
 - rosbridge_library.capabilities.publish.Publish
 - rosbridge_library.capabilities.subscribe.Subscribe
 - <class 'rosbridge_library.capabilities.defragmentation.Defragment'>
 - rosbridge_library.capabilities.advertise_service.AdvertiseService
 - rosbridge_library.capabilities.service_response.ServiceResponse
 - rosbridge_library.capabilities.unadvertise_service.UnadvertiseService
[ INFO] [1528699326.314381215]: using default calibration URL
[ INFO] [1528699326.314605012]: camera calibration URL: file:///home/ubuntu/.ros/camera_info/head_camera.yaml
[ INFO] [1528699326.314734331]: Unable to open camera calibration file [/home/ubuntu/.ros/camera_info/head_camera.yaml]
[ WARN] [1528699326.314789434]: Camera calibration file /home/ubuntu/.ros/camera_info/head_camera.yaml not found.
[ INFO] [1528699326.314889952]: Starting 'head_camera' (/dev/video1) at 320x240 via mmap (yuyv) at 30 FPS
[INFO] [1528699326.391895]: Controller Spawner: Waiting for service controller_manager/load_controller
[INFO] [1528699326.396982]: Controller Spawner: Waiting for service controller_manager/switch_controller
[INFO] [1528699326.401629]: Controller Spawner: Waiting for service controller_manager/unload_controller
[INFO] [1528699326.405661]: Loading controller: jet_drive_controller
[ INFO] [1528699326.425809648]: Controller state will be published at 100Hz.
[ INFO] [1528699326.431966261]: Wheel separation will be multiplied by 1.
[ INFO] [1528699326.436829625]: Left wheel radius will be multiplied by 1.
[ INFO] [1528699326.436918268]: Right wheel radius will be multiplied by 1.
[ INFO] [1528699326.439194824]: Velocity rolling window size of 10.
[ INFO] [1528699326.443069516]: Velocity commands will be considered old if they are older than 1s.
[ INFO] [1528699326.445152952]: Allow mutiple cmd_vel publishers is enabled
[ INFO] [1528699326.449440029]: Base frame_id set to base_link
[ INFO] [1528699326.451265399]: Odometry frame_id set to odom
[ INFO] [1528699326.455106446]: Publishing to tf is enabled
[ INFO] [1528699326.501753161]: Odometry params : wheel separation 0.36, left wheel radius 0.077, right wheel radius 0.077
[ INFO] [1528699326.509993418]: Adding left wheel with joint name: left_wheel_joint and right wheel with joint name: right_wheel_joint
[ WARN] [1528699326.548523676]: updateConfig() called on a dynamic_reconfigure::Server that provides its own mutex. This can lead to deadlocks if updateConfig() is called during an update. Providing a mutex to the constructor is highly recommended in this case. Please forward this message to the node author.
[ INFO] [1528699326.559528497]: Dynamic Reconfigure:
	Odometry parameters:
		left wheel radius: 1
		right wheel radius: 1
		wheel separation: 1
	Publication parameters:
		Publish executed velocity command: 0
		Publication rate: 100
		Publish frame odom on tf: 1
[INFO] [1528699326.575270]: Loading controller: joint_state_controller
[ERROR] [1528699326.582050625]: Could not load controller 'joint_state_controller' because controller type 'joint_state_controller/JointStateController' does not exist.
[ERROR] [1528699326.582133019]: Use 'rosservice call controller_manager/list_controller_types' to get the available types
[ WARN] [1528699326.664365016]: unknown control 'focus_auto'

[INFO] [1528699326.923410]: Rosbridge WebSocket server started on port 9090
[ERROR] [1528699327.584324]: Failed to load joint_state_controller
[INFO] [1528699327.585210]: Controller Spawner: Loaded controllers: jet_drive_controller
[INFO] [1528699327.605870]: Started controllers: jet_drive_controller
[ERROR] [1528699343.433569]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I get this error no matter what I roslaunch.

I am certain I setup my ips in both /etc/hosts and ~/.bashrc correctly.

I’m at a loss, help would be much appreciated!

Additional Question: Will running roslaunch execute my code onto the robot?

I have the same error when run:

source ~/.bashrc; source ~/catkin_ws/devel/setup.sh; roslaunch jet_bringup jet_real.launch
So, has anyone solved the problem?

It looks like the issue might be coming from the code that is trying to connect to the Arduino. I wonder if you somehow failed to upload the code to the Arduino? Maybe a USB hub issue - can you try using different ports for the on/off buttons. Is the port on where the Arduino is plugged in?

A ROS version issue with Ubuntu could be the problem as well we haven’t updated our codebase in a while for this.

I have checked the USB hub,and I’m sure it’s no problem.
So, what could I do next for this error?