tx1 serial port problem

Hi,everyone,

When I use tx1 I find that there is only one uart worked well in cutecom, which is uart0, and the other three even can't be open. And that mean the uart1(which is the serial port on the carrier board) can't be open.

Does anyone  have met the same situation?

Thanks

The serial console is of course already in use ("/dev/ttyS0"), but I’ve used the 6-pin J17 port after removing the camera module ("/dev/ttyTHS2"), plus added serial UARTs via USB ("/dev/ttyUSB*").

Is your cutecom program running on a separate host? I just tried the serial port from my host and it worked (115200, 8N1, hardware flow control…at the host end its a USB serial UART, at the Jetson end it’s “/dev/ttyS0”).

I don’t know about the other ports.

Hi linuxdev

Thanks for your reply.

I use cutecom on tx1, and the other side is on a windows pc. So you mean if I want to use the J17, I must remove the ‘/dev/ttyTHS2’ first? – until now I haven’t do this, and I can’t open the J17 port in cutecom.

The file “/dev/ttyTHS2” should be there if the driver is running…it’s the physical hardware I’m talking about. J17 has wire traces going to the camera module. The camera module is removable, it has two screws to remove, and then it lifts straight out of the connector it seats on. My concern is that it is possible camera hardware could interfere with using J17 for general purposes if the camera is left in place. Without “/dev/ttyTHS2” J17 cannot function; with the camera also connected to those same pins, non-camera use might at times act strange.

Thanks.

Finally I remove the camera hardware, and open the “dev/ttyTHS2” in cutecom, and the J17 work well.I wonder how you know the “/dev/ttyTHS2” represent the “camera serial port”?

And when I use the uart in J21("/dev/ttyS0"), I found that tx1 to windows pc is right, but windows pc to tx1 has something wrong. For example when I send from pc to tx1 7 or 8 times, only once data can pass right, and sometimes pc receive a lot of wrong data even I didn’t send any on tx1. – J17 work well not like this. I think this has something to do with the uart0 receive mux hardware. Did you met this situation?

I’ve just worked on JTX1 serial before so I’ve seen it. The schematic also shows J17 which can be traced to the camera.

I don’t use windows (I’d have to lose DHCP via host and other things would be lost if I did that), but serial port issues often resolve around one of these symptoms (regardless of host o/s):

  1. No data
  2. Corrupted data
  3. Intermittent data

Corrupted data tends to be invalid TX/RX speed mixes, but other settings correct. No data also tends to be invalid TX/RX speed mixes which are very far from correct, though sometimes other settings are an issue. Intermittent data tends to be operating at the edge of valid signals, especially with software flow control (hardware flow control allows pushing things much further).

In the case of being at the edge of valid signals, I might suspect hardware flow control is not enabled; or for one direction of a pipe not working perhaps CTS/DTS flow control is enabled on only side of the pipe (the two end points must match for all settings). I suspect data rate, bits, and parity are correct, but perhaps you still need to set CTS/DTS at both ends and currently only one end is set that way; if both are software flow control, then it implies signal timing is better in one direction than the other.

Ok,

I’ll debug it days later and focus on the CTS/RTS signal.

thanks very much!