[TX1] System configuration wizard didn't come out after completed the flashing

Hi experts,

I’m flashing TX1 using SDKManager. A HDMI monitor was connected to the board.
After completed the flash, the host indicates me to type in the username and password.
But there was no “System configuration wizard”, actually nothing, showing on the monitor. I just cannot setup the board, not to speak of typing username and password in the host “Install SDK components on your Jetson TX1”.

Could you tell me how to make the board to show the “System configuration wizard” and continue the components flashing?

Thanks a lot.

Hi microlj,

After flash completed but your TX1 doesn’t show up first boot init setup process?
What’s your monitor show? and what’s your uart log show?

The correct steps is:

  1. Flash image
  2. Setup username and password on your TX1 (connected HDMI monitor)
  3. After device boot into desktop
  4. Flash SDK components.

Hi carolyuu,

After flash completed but your TX1 doesn’t show up first boot init setup process?
Yes, TX1 shows nothing. it just has no any response.

What’s your monitor show? and what’s your uart log show?
I’m using a SAMSUNG monitor, model: S22E450F, connected to the TX1 with HDMI

After the flash completed, SDKManager terminal shows “install ‘Flash Jetson TX1’ success”, and the TX1 just has no any response, not show up first boot init setup process.

I don’t know where the uart log is.

Step is correct.

Hi microlj,

Please try flash by manually:

  1. Go to /home//nvidia/nvidia_sdk/JetPack_4.2.2_Linux_GA_P2180/Linux_for_Tegra
  2. Put TX1 device into recovery mode
  3. Flash:
    $ sudo ./flash jetson-tx1 mmcblk0p1

After flash finished, please check your TX1 monitor can show boot init setup process or not. Thanks!

Hi carolyuu,

tried the cmd: “sudo ./flash.sh jetson-tx1 mmcblk0p1”
I think the system flashed successfully, but still not show up anything.

command line ended successfully:

[ 167.9534 ] Flashing completed

[ 167.9535 ] Coldbooting the device
[ 167.9566 ] tegradevflash --reboot coldboot
[ 167.9579 ] Cboot version 00.01.0000
[ 167.9600 ] 
*** The target t210ref has been flashed successfully. ***
Reset the board to boot from internal eMMC.

Hi microlj,

It’s so strange.
Could you try change others HDMI monitor or change the HDMI cable?
Before flash the image, does your TX1 HDMI port workable?

Hi carolyuu,

This TX1 board is not mine, and I don’t think it is official release. Then I checked with the one who gave the board to me.
He said the firmware doesn’t support JetPack4.2.1 or 4.2.2.

I don’t know why the firmware is an issue. The board is different with the official? Not sure.

Just a comment on firmware…

When you have a module it mounts onto a carrier board. The default software assumes the development kit carrier board. If you have an alternate carrier board, then changes to the routing of various pins needs to be accounted for via a change in the device tree (pins often have a series of optional functions they can switch between to accommodate flexible routing). The device tree is sort of a generic means of telling the drivers which pin has which function.

Flash includes software for the module and for the carrier board. If you have a TX1 module, then the default JetPack/SDK Manager will always work with the module, but a third party manufacturer carrier board will require adding their device tree modifications prior to flash so that this routing of pins is correct. A newer release may not be compatible with a particular custom carrier board until the device tree is updated, and NVIDIA cannot know what is in such a carrier board. Which means that the manufacturer provides that device tree for any given release. This can lead to officially supported releases not working directly with third party carrier boards (parts would probably work, but not all parts).

If this is the development kit with its carrier board, then you’re already set for newer releases. If this is a third party carrier board, then you might check with the carrier board manufacturer’s web site to see if they have an update for this more recent release. Either way you will need to state if your carrier board is from the dev kit, or if it was a separately purchased third party carrier.

This URL shows an image of a module on a development kit carrier board:

Hi linuxdev/carolyuu,

Many thanks for your help. I think I got the problem. Now the third-party manufacturer is helping me to bring it up.
Thanks the help and the detailed firmware explanation.