TX1 TTYS0 UART Debug, Fail to Powerup

Hello there. I have a device on the TTYS0 UART, and it brings up before the jetson, sending some data to Tx1 from the UART port, which u-boot confuses it to be a keyboard input, and it enters to the boot debug mode.

I don’t want this happening, and I tried to modify the u-boot source codes, built it again, and flashed the u-boot.

export DEVDIR=/home/burak/JetPack-L4T-3.3/64_TX1/Linux_for_Tegra
export CROSS_COMPILE=/usr/local/gcc-linaro-5.3-2016.02-x86_64_aarch64-linux-gnu/bin/aarch64-linux-gnu- 
export CROSS32CC=/usr/local/gcc-linaro-5.3-2016.02-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf-gcc 
export KERNEL_MODULES_OUT=$DEVDIR/images/modules
export TEGRA_KERNEL_OUT=$DEVDIR/images
export ARCH=arm64

cd $DEVDIR/sources/u-boot/
make distclean
make p2371-2180_defconfig
make
sudo cp -f $DEVDIR/sources/u-boot/u-boot* $DEVDIR/bootloader/t210ref/p2371-2180/
cd $DEVDIR/
sudo ./flash.sh -k LNX jetson-tx1 mmcblk0p1

I managed to flash the uboot, and it boots up fine after the flash.

But when I power off/power on, it wont boot, only black screen. (Doesn’t even push debug messages to the serial port)

I switched back the u-boot modifications, but I still can’t boot. It only boots when I flash it. (dtb or uboot…) Now I can’t manage to fix my Tx1, it only works if I flash it, and doesn’t work if I dont.

I help need on three questions;

  1. How do I compile the u-boot and flash it the correct way?
  2. How can I close the ttyS0 Uart Debug console? So it won’t enter to the boot debug mode when the device sends data?
  3. How can I fix now-broken tx1? Getting the original .bin files and flashing again didn’t seem to work.

Thank you.

Here are the results of me trying to flash the u-boot if anyone is interested;

log_EBT_flash.txt (15.1 KB)
log_LNX_flash.txt (11 KB)

Downloaded a fresh Jetpack 3.3, and flashed the tx1 with it.

It booted up just fine after the flash, sending debug messages through the serial as well (checking with usb-serial of my host pc.)

I didn’t do anything, pressed the power button and held it down. It shut down.

After that, tried to boot it again with pressing 1 time to the power button. Still, it can’t cold boot. Only black screen, not even serial debug.

Also, the jetson + board used to draw 0.5A of current when it worked without problems, but now it draw 0.3~A. So it makes me wonder if the Jetson even gets power.

EDIT: When I power it on, tried to run the command which should’nt be successfull since the device is not in recovery mode;

sudo ./flash.sh -k LNX jetson-tx1 mmcblk0p1 2>&1 | tee log_LNX_flash.txt

Which actually was successfull flashing. I just powered it on, didn’t put it into Recovery Mode myself.

I figured it automatically enters to the Recovery Mode by itself.

FYI, the Jetson will never automatically go into recovery mode. The recovery button must be held while cycling power for that to occur.

Still having problems with this. Is there any -proven- u-boot compiling and flashing resource/guide I can use?

Thank you.

Which specific release (instructions differ depending on release)? There is a U-Boot customization section in the official docs. If you go here, and then click on the particular release:
https://developer.nvidia.com/embedded/linux-tegra-archive
…there would be a “Documentation” URL. This is html format documentation and you can use your web browser to see the U-Boot content.