tx1 uboot console

im using a custom carrier board, where uart0 is not connected,and uart1 is connected instead.
how do i modify uboot to use it as console?

i tried changing stdout-path
in 64_TX1\Linux_for_Tegra_64_tx1\sources\u-boot_source\arch\arm\dts\tegra210-p2371-2180.dts
also, in 64_TX1\Linux_for_Tegra_64_tx1\sources\u-boot_source\include\configs\tegra-common.h changed
that didnt work.

the uart does work as a linux getty, after changing extlinux.conf and kernel_source\arch\arm64\boot\dts\tegra210-common.dtsi

another question , why are the uart addresses different in the linux tegra210-common.dtsi and the uboot tegra210.dtsi?

hello ronjac,

please try to have a modification for below uart definition.


/* Board-specific serial config */

Hi Chang,

If .ı want to disable the uboot uart completely, what should i do?


hello bm2017,

please try to modify you u-boot pinmux configuration.
please have a try to change the pin to GPIO, or disabling the output driver (set tristate)