TX1 Using USB2 from J18 (M2-Key Exp Slot)

I want to use one extra USB other than USB2.0 and USB3.0 slot.
So i am thinking about using USB2 pins provided in J18 connector (M2-Key Expanstion Slot).
Pin-3 USB2_D_P
Pin-5 USB2_D_N

I want to connect upstream of USB hub IC to this pins.
I connected USB D+, D- and GND to HUub IC’s upstream. But this not works…!!

So do i need to update kernel or dtsi file to enable USB2 ? or still some hardware connection fault from my side?

Extremely Sorry…
hardware Fault from my side…
Now USB 2 is working with USB hub IC.

Hello,

I am interested in how you enabled USB2 on the M2-Key Slot (USB2 Port 3).

Did you have to update the kernel driver and dtsi file?
Or did you succeed just by using some default kernel and device tree files?

Currently, I am using default 24.2.1 L4T and I cannot see usb2 port 3.
I have connected some device pulling out the lines from M2 connector but no luck.

Hello,

Same problem Here.
How to enable USB2 on the M.2 E Key Slot??

I’m also trying to connect an USB hub to this port, but it seems like this port is always in suspend state.
I am using Ubuntu 16.04 LTS

Thanks!

In my case, USB2 is working without any software changes.
When I connect USB D+, D- and GND to an external USB Hub IC’s upstream, It’s detecting my USB hub IC in lsusb. And devices attached to this hub is also working.

You might try passing this to the kernel command line (this should be ok in the APPEND of extlinux.conf, though perhaps this changes in R28.1):

usbcore.autosuspend=-1

I’ve tried to set usbcore.autosuspend to -1 refer to this link
http://www.jetsonhacks.com/2015/05/27/usb-autosuspend-nvidia-jetson-tk1/
but with no luck.

I plug and unplug USB devices on this USB port several times but no message shows up on the console screen.
just like this USB port is totally dead.

What else could I try?

Thanks!

When you say nothing shows up on the console screen, what are you checking? Does “lsusb” (before and after plug) or “dmesg --follow” show any activity?

When I connect a device to USB port, it supposed to show such message like
“usb 1-3.1.4: new USB device found, …”
unplug device shows “usb 1-3.1.4: USB disconnect, …”

but when i plug or unplug device on USB port2 which is in the M.2 Slot(J18), it shows nothing on screen
no activity shows in “lsusb” and “dmesg --follow” before/after plug
in short, just like this usb port doesn’t have any function

I was wonder if kernel disable this port by some reason?
and how could i avoid that and enable this port?

I have not tried to use this port, someone in a post further up said it works. If there is no function it seems highly likely it is a device tree issue. One thing you might do is to view the D+/D- data pair in an oscilloscope and see if you see activity as a result of connecting…a sign that the PHY is at least active. If there is activity, then it seems any failure would be in controller setup…if there is no activity, then it seems the PHY is not set up or has failed.