TX1 WiFi Configuration Help

I can’t connect to my WiFi network with the wpa_cli tool. I am using the guide here: https://shapeshed.com/linux-wifi/. Nothing happens after the

enable_network 0

step. Noticed that when I start wpa_cli it says

Selected interface 'p2p-dev-wlan0'

which I do not see in the output of

ifconfig -a


ip a

Any help would be appreciated, thank you.

Hi vectrasoft,

Do you add p2p-dev-wlan0 interface?

In /etc/network/interfaces, Add below
   auto p2p-dev-wlan0
   iface p2p-dev-wlan0 inet static

That did nothing.

I realized wpa_cli chose the p2p-dev-wlan0 interface by default, so I tried:

wpa_cli -i wlan0

This allowed me to configure the network, enable it, and successfully connect - BUT - save_config always fails. This is a problem because a failing save_config means every boot of the TX1 I need to manually configure the network - not good for a robotics project.
Can you explain what the p2p-dev-wlan0 interface is? Is there a way to use wlan0 interface and get it properly configured permanently?

Solved! /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid MYSSID
wpa-psk "PASSWORD"