Tx2-4g r32.3.1 i2s->bclk_ratio currupted

In tegra210_i2s_alt.c, it gets set to 1 as default.

later in tegra210_i2s_hw_params it is a very large number, so it messes up the dev_err(dev, “Can’t set channel bit count bc %d mask %d ic %d sr %d\n”, bitcnt, TEGRA210_I2S_TIMING_CHANNEL_BIT_CNT_MASK, i2sclock, srate);
the bit count goes negative.

I changed to the code to ignore bclk_ratio and bit count is ok for now.

I am trying to get tlv320aic3100 codec working. This is how I came across this problem

Hi terrysu50z,
Thanks!, There are three ways this bclk_ratio value can get changed.

  1. DTS node
  2. Mixer control settings.
  3. set_bclk_ratio callback on i2s driver

Assuming you have not set (1) and (2) . Can you check tegra210_i2s_set_dai_bclk_ratio() function ratio value, This ratio value would be from machine driver configuration which needs to be checked.

I guess I went into alasmixer and set the bclk_ratio to 1, and removed my debug code and it is working.

Thanks,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.