TX2 and auvidea J130 + InES-HPMM kernel

I’m working on an auvidea J130 + TX2 and I’m testing the kernel https://github.com/InES-HPMM/linux-l4t-4.4 because I need tc358840 driver but I cannot initialize the toshiba chip:

tc358840 2-000f: camera_common_regulator_get vif ERR: fffffffffffffdfb
tc358840 2-000f: cannot get regulator vif -517
tc358840 2-000f: Couldn’t power init
tc358840 2-001f: camera_common_regulator_get vif ERR: fffffffffffffdfb
tc358840 2-001f: cannot get regulator vif -517
tc358840 2-001f: Couldn’t power init

Auvidea is not giving any informations and almost every answer of their support department is useless.
As I can understand the dtsi doesn’t initialize the regulator but the file provided by auvidea and/or by the InES-HPMM tree are the same and are not ok.

Does anyone solved the problem?

Thank you

Hello , Have you been able to solve the issue ? I have the exact same problem for my custom board . I am not sure how should i change the dts file to get rid of this error .let me know if you have any updates.

actually not …auvidea doesn’t answer to tickets and I’ve not found a solution …I’ll keep you posted

Please ignore error of power init.

I compiler TX2 kernel from https://github.com/InES-HPMM/linux-l4t-4.4 and tc358840 drive

I can load the tc358840 module but I can not see the device /dev/video0 and /dev/video1.

ubuntu@tegra-ubuntu:~/weng/HDMI_tc358840$ lsmod
Module Size Used by
tc358840 43372 0
fuse 89760 2
bcmdhd 7634040 0
pci_tegra 75137 0
bluedroid_pm 13564 0

Does anyone have the same problem ?

Hello weng.cs

I tried the kernel , it worked for me . And I didn’t load the driver as module but as internel driver. Maybe you can try that way .

the driver works as expected using for example the board from www.pender.ch but it doesn’t work with the auvidea J130 because they have not released the DBC/BDS for tc358840

Oh yes , I forgot to mention that i tried with the official board . not the auvidea’s one . apology

Thanks for your reply.

Hi have someone tried to work something out on his own? Since there is no real info on when Auvidea will release this, I have tried to patch this myself, with no success at the moment.

From sources I gathered you have to modify the csi_port in the dts file and maybe (not sure nor which) some gpio pins as they are not the same on the j130. After hundreds of different tests, the reason why the driver can’t load (thus no dev/video* appearing) is mystifying.

Same here!

I think that the board is broken in some way. I’ve not solved the problem after so many emails, tickets and so on.

I’m thinking about designing a new board with some additional features like nvme support.

I cannot wait auvidea forever and I don’t trust them anymore.