TX2 CAN Device seems error!

Platform: Nvidia TX2 tegra-ubuntu 4.4.38-tegra.
I follow the instructions from https://devtalk.nvidia.com/default/topic/1006762/jetson-tx2/how-can-i-use-can-bus-in-tx2-/post/5178022/#5178022

1.I can directly apt-get install can-utils because of can locate the can-utils . so I download from github

https://github.com/linux-can/can-utils

2.I have a USB-CAN from one PC to send can packets to TX2 every 500ms . If I run $sudo ip link set up can0 with USB-CAN is sending msg at the same time , then I can get $candump can0 with none msgs. but if I run sudo ip link set up can0 without USB-CAN is sending msg It works fine. this is the problem 2
3.When I stop USB-CAN send msg . $candump can0 still get a lot of msgs. unless I remove the can cable connect to TX2. This is the problem 3
Any helps would be aprreciate . Thanks a lot

Hi 447825937,

Are you using R28.1? Could you try with R28.2 which just released?

Thanks

Thank you kayccc,
That is because I mistake connect CAN_H and CAN_L to TX and RX . It works now .
Thank you for your reply .