TX2 can0 port configuration failing to set

Hey all,

I am having major trouble disabling the can0 loopback off.
I have followed the instructions here: https://docs.nvidia.com/drive/active/5.1.3.0L/nvvib_docs/index.html#page/DRIVE%20Linux%20AGX%20PDK%20Development%20Guide%2FInterfaces%2FAppxTegraCAN.html%23wwpID0E04D0HA

output:
sudo ip link set can0 type can loopback off
sudo ip link show can0
4: can0: <NOARP,ECHO> mtu 16 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 10
link/can

I have tried this while turning can on, and this is set as default in: /etc/network/interfaces (see below)

auto can0
iface can0 inet manual
pre-up /sbin/ip link set $IFACE type can bitrate 1000000 loopback off
up /sbin/ifconfig $IFACE up
down /sbin/ifconfig $IFACE down

I have also triednot including ‘loopback off’ at all to see if it would fix it.
I have tried restarting the TX2 after any modification to /etc/network/interfaces as to be expected.

Does anyone know a fix or workaround to this?

can0 works otherwise and can transmit/recieve.
However the echo is taking precious compute power.

Thanks,
Jean-Luc

Hi Jean-Luc,

By default running “ip link set can0 type can bitrate 500000” loopback is off
Please let me know what you are trying to achieve and where exactly are you facing issue? I did not get your problem. Please specify some more details, I would be able to help more.

Thanks,
Shubhi