TX2 Dev Board not powering on

Hi all. I understand this problem has been faced before, but I would try asking here in case there is a practical solution now.

I have a TX2 development board that is a few months old. I have been using it for awhile now for various programs (ROS and such). Earlier today I was doing some code editing, then the TX2 just shutdown abruptly (like a power cut).

When I tried to reboot it, it no longer works. When the power cable is attached, the red LED lights up. However, there is no response at all when I press the power-on button (no other LED lights up)

I have tried holding the power button, pressing it rapidly in succession, pressing the reset button, and attempting to go into Recovery Mode. I have also removed all other cables (USB, HDMI) just in case they were the cause.

I am using the official power brick provided to power the TX2.

Does anyone has any idea what’s going on here? Any help will be much appreciated. Thank you.

If even recovery mode failed, I would say this may be a hardware issue.
Please check with RMA process.