TX2 HDMI Disable / i2c transfer timed out addr: 0x50

A bit of a n00b with the jetson and embedded linux but…
Currently we are using a custom carrier board and we are seeing the following during the end of boot for approximately 5 minutes or so:

[ time ] tegra-i2c 3190000.i2c: i2c transfer timed out addr: 0x50
[ time ] tegra-i2c 3190000.i2c: rx dma timeout

From what I’ve read this is likely due to the HDMI being enabled (which we dont have on the carrier) and would require us to disable the HDMI. I also haven’t found an exhaustive i2c address listing.

I’ve read a few related topics on this:
https://devtalk.nvidia.com/default/topic/924709/tx1-kernel-keeps-throwing-i2c-3-error-during-boot-up/
https://devtalk.nvidia.com/default/topic/1023861/

We are currently using the latest (I believe) of Tegra 28.1.

I’m exactly unsure how find the dts files and how to compile the dtb needed in order to fix the issue. They don’t seem to be in the locations I’ve seen listed.

Any help on this is appreciated.

The i2c for HDMI is part of HDMI’s hotplug…when no monitor is attached on a regular carrier board there is no error. If this is from the HDMI, then it would imply that something is also telling the system that HDMI is present, else it would not have done an i2c query (DDC/EDID). It might be HDMI, but I’m not convinced unless other errors are triggering the HDMI query (the existence of HDMI and enabling of the ability to query HDMI will not directly lead to an i2c query running).

Hi afunk,

Please try to disable SOR1 in the device tree to see if this logs disappear.
If you want to know which device tree you are flashing. You can refer to p2771-0000.common.conf (for jetson-tx2 .conf), there is a DTB field.