TX2 HDMI hotplug issue

I have a hdmi issue on tx2 when runing customized system(based on jetpack3.1):

Pull down and then plug in HDMI,moniter entering power save mode,nothing output unless run “sudo service lightdm restart”.

I want HDMI keep output.

How should I solve this problem?

You might post the content of “dmesg --follow” which occurs during unplug and replug.

FYI, for hot plug to work correctly the monitor EDID must work, and the EDID must be within one of the predefined values of the driver. You see if this file is empty, or if it has hex data (it should have hex data if EDID is good):

sudo -s
cat `find /sys -name edid`

Once you know that EDID exists before and after the unplug/replug you can narrow down as to what the driver thinks of that EDID via adding this to ‘Section “Device”’:

Option    "ModeDebug"

…then reboot, and check the content of “/var/log/Xorg.0.log”. The driver will explicitly tell you what it thinks of every EDID mode and what it has chosen or rejected. The log after unplug/replug would also give some valuable information, but you’d want to post just a simple log from after a normal reboot first.

Thanks a lot.

Do we have any way keep the HDMI output under Framebuffer mode?
In FB mode,pull down the HDMI,rgb video write error to /dev/fb0,then HDMI pluged in,moniter entering power save mode.EDID have hex data but nothing output on the moniter.

I have not attempted to use framebuffer mode directly, but I’ve seen people working with the framebuffer, so it seems possible. I couldn’t tell you how. Someone from NVIDIA may have that information for you.

Many thanks.

I find a way to keep HDMI output in FB mode, Pull Down HDMI-detect IO on customize board.
I don’t know if there is any better way.

Have you resolved your problem?