tx2 iwconfig wireless extentions

I am working on a tx2 dev kit and am trying to get information with iwconfig. When I run ifconfig I get:

wlan0     Link encap:Ethernet  HWaddr 00:04:4b:a8:4e:bf  
          inet addr:  Bcast:  Mask:
          inet6 addr: 2603:3021:1101:3800::fee7/128 Scope:Global
          inet6 addr: 2603:3021:1101:3800:7f82:8d7d:dcbf:1302/64 Scope:Global
          inet6 addr: fe80::650d:f429:1c50:e8c6/64 Scope:Link
          RX packets:31630 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10121 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9674880 (9.6 MB)  TX bytes:1015992 (1.0 MB)

So I am actually on the internet using wlan0. However, when I run iwconfig I get:

usb0      no wireless extensions.

lo        no wireless extensions.

dummy0    no wireless extensions.

wlan0     no wireless extensions.

ppp0      no wireless extensions.

l4tbr0    no wireless extensions.

usb1      no wireless extensions.

tunl0     no wireless extensions.

eth0      no wireless extensions.

None of my connections appear to work with iwconfig. Does anyone know why this is the case?

iwconfig uses the old wireless extensions (WEXT) kernel interface rather than the newer CFG80211/NL80211 interface, and the TX2 kernel doesn’t have CONFIG_CFG80211_WEXT, which provides the compatibility interface for the older wireless extensions.

You can either rebuild the kernel with that configuration option enabled, or switch to using the iw tool instead of iwconfig. iw uses the newer API.