TX2 Jeston board - NVDISPLAY & mcerr fault error in kernel log file


MIPI VI port (NVDISPLAY) of TX2 board isn’t working now. So, I checked the kernel log file (dmesg command) as attached (klog.txt).
There are errors ( “Unhandled context fault” and “unknown mcerr fault”).

  1. What are these errors?

  2. How to check hardware part (MIPI VI port, NVDISPLAY) is working or not? Is there any debugging firmware to check hardware damage?

  3. When using flash.sh command to update dtb file, I can’t use update dtb file only, other flash area looks like fine. Now I use FDT command in TX2 target board to indicate new dtb file location instead of flash.sh update. How can I know NAND flash memory area is broken or not. Is there any anaylsys program?

  4. If the issue is in the hardware parts, How can I get repair service ( A/S center store) in USA ( San Jose )?

klog.txt (75.7 KB)

It is a known issue when you point dtb by using FDT. If you directly flash the dtb, this issue would not happen.

This should be resolved in next release.

Thank you for your help.

By the way, suddenly I couldn’t update dtb file. So, used FDT command.
After rewriting my dtb file into dtb folder on host PC, and using the command as
“sudo ./flash.sh -r -k kernel-dtb jetson-tx2 mmcblk0p1”. I always see dtb file update successful message . But, when I checked kernel log file, It’s not update ( check dtb file time/date). I can update whole files except dtb file. So, could I change dtb flash area using the configuration file or command manually if flash memory area has error ( damage ) or how to check dtb file flash writing is correct or not?


If you write anything to the dtb and it is successfully updated, then the change will be seen in /proc/device-tree.

For example, adding arbitrary string “12345” in dts, build it to dtb and flash it to device, then you shall see “12345” under /proc/device-tree with corresponding path.

If you don’t see it, it means

  1. dtb update was failed.

  2. Other dtb is in use. For example, if you have FDT assigned, then the flash will not help because the system always uses the one indicated by FDT.


I checked the new dtb file configuration (nvidia.dtbbuildtime, etc) in /proc/device-tree. but, It’s old one. Where is dtb file located ( default location if not use FDT command)? Is there method to change DTB location ( emcc memory area )?

Default location is the kernel-dtb partition in emmc.

Where do you put this new dtb? I mean which path do you copy and paste the dtb file to.


I put new dtb file in “~/nvidia/nvidia_sdk/JetPack_4.2_Linux_GA/JetPack_4.2.2_Linux_GA_P3310/Linux_for_Tegra/kernel/dtb” folder. Do I need to put the dtb file “…/Linux_for_Tegra/bootloader” folder? If using “dtc” program to convert dts file, I can see old dtb file in “bootloader” folder instead of “kernel/dtb” folder.


This path is correct. Are you sure you already removed FDT from extlinux.conf?
Could you also show me the boot up log from uart?

Oh… one more thing to check, are you sure your dtb name is correct?


I updated whole package (system.img) using command as below.
“sudo ./flash.sh -r -k APP jetson-tx2 mmcblk0p1”. I mean, extlinux.conf is default value and checked the configuration (there isn’t FDT coammnd ). I’m using “tegra186-quill-p3310-1000-c03-00-base.dtb” file. I’m not using UART now. I’ll connect UART and update boot log file. ( I just use “dmesg” to check kernel boot log.). I’m going to try to re-packaging of system.img to replace old dtb file.

By the way, I had been using dtb flash well. but suddenly dtb flash wasn’t working (not updated). So, I doubt the emcc memory is failed

If emmc partition has problem, the uart log will tell.
Only uart log has the log from bootloader. dmesg only has kernel log.


I have solved the issue (dtb flash writing issue). old dtb file was in “Linux_for_Tegra” folder instead of “Linux_for_Tegra/kernel/dtb” folder. I think shell script firstly check dtb file from “Linux_for_Tegra” folder, then check “Linux_for_Tegra/kernel/dtb” folder.

I’m going to check my driver and application are working. I hope all issue is solved.

Thank you for your help.

That sounds new to me. The flash log shall give you the path of the dtb.

Let me check it on my side too. Thanks