TX2 Jetpack 4.3 USB port inactive after flashing

Problem: The usb cannot work after i flashing 4.3(18.04 Ubuntu). I saw there are some similar cases also happened for 4.2 or other version, but seems the format in 4.2 and 4.3 are different?
here is a sample: other answer looks like this: vbus-supply = <&vdd_usb0_5v>; but my code looks different: vbus-0-supply = <0xa8>; so i dont know how to convert <&vdd_usb0_5v> to <0x??> and i tried to change several times, but there is no use at all.
Is there any suggestion to modify the tegra186-quill-p3310-1000-a00-00-base.dtb(dts) or tegra186-quill-p3310-1000-c03-00-base.dtb(dts), or someone can help provide the sample code?
Here is a part of code
pinctrl@3520000 {
compatible = “nvidia,tegra186-xusb-padctl”;
reg = <0x0 0x3520000 0x0 0x1000 0x0 0x3540000 0x0 0x1000>;
reg-names = “padctl”, “ao”;
resets = <0x10 0x37>;
reset-names = “padctl_rst”;
clocks = <0x10 0x6f 0x10 0x215 0x10 0x87 0x10 0x86>;
clock-names = “xusb_clk”, “utmipll”, “usb2_trk”, “hsic_trk”;
interrupts = <0x0 0xa7 0x4>;
mboxes = <0xb0>;
mbox-names = “xusb”;
#phy-cells = <0x1>;
status = “okay”;
vbus-0-supply = <0xa8>;
vbus-1-supply = <0xa9>;

I also tried to use 4.2 dtb file to replace but seems it is not working.

Thanks a lot.

Hi,
Programming of USB land mapping is different between Jetpack3.* and Jetpack4.*. It is identical in 4.2 and 4.3. Please refer to
https://developer.nvidia.com/embedded/dlc/Tegra_Linux_Driver_Package_TX2_Adaptation_Guide

There are some examples:
https://devtalk.nvidia.com/default/topic/1066610/jetson-tx2/jetson-tx2-usb-2-3-connection-/post/5402116/#5402116
https://devtalk.nvidia.com/default/topic/1057885/jetson-tx2/usb-not-working-in-jetson-tx2-r32-2/post/5364464/#5364464
FYR.

Hi, DaneLLL,

Thanks for replying so fast. i was trying to edit some files in sources folder including:
tegra186-quill-p3310-1000-c03-00-base.dts;
tegra186-quill-p3310-1000-a00-00-base.dts;
tegra186-quill-p3310-1000-a00-plugin-manager.dtsi;
tegra186-quill-power-tree-p3310-1000-a00-00.dtsi;

I found dts file in sources folder cannot be compiled to dtb file directly through “dtc” command.
according to another post: https://devtalk.nvidia.com/default/topic/1024229/jetson-tx2/jetson-tx2-board-device-tree-compilation-error/ The file is not purely device tree.
so i try to follow the standard procedure to compile the kernel: https://developer.ridgerun.com/wiki/index.php?title=Compiling_Jetson_TX2_source_code_L4T_32.1

After i export ARCH=arm64 and clean make, when i do “make -C kernel/kernel-4.9/ O=$TEGRA_KERNEL_OUT tegra18_defconfig” there is an error “Can’t find default configuration “arch/arm64/configs/tegra18_defconfig”!”
i checked the folder and there is really no such file.
May I know where i can get the file or there any step missing or there is a simple way to solve my problem directly?

really thank you for helping:)

Hi,

Please refer to L4T document directly. If you see refer to a guide with some files like “tegra18_defconfig”, then it was for old release. After rel-32.x, all platforms are using tegra_defconfig.

Hi WayneWWW,

Thank you for replying. Now the problem has been fixed.
Here are what i did:
Firstly, I download the source and follow change from https://devtalk.nvidia.com/default/topic/1049988/jetson-tx2/third-usb-on-custom-board-not-working-with-jetpack-4-2/post/5330117/#5330117
Then follow the steps from https://developer.ridgerun.com/wiki/index.php?title=Compiling_Jetson_TX2_source_code_L4T_32.1#3._Compile_kernel_and_dtb to compile the sources.
Replace the certain .dtb files and flash the TX2 again.
Finally it works.

Thank you for helping.