TX2: Lauterbach Trace32 JTAG Debugger?

Has anyone succeeded in using the Lauterbach Trace32 JTAG debugger with a TX2, especially under R28.1?

Still interested in this. Has anyone tried the Trace32 debugger on a TX2? Is there any other JTAG debugger known to work with a JTX2 (especially R28.1)?

I tried Trace32 debugger on a TX2 (R27.1).
But I have not been able to disable watch dog.

So I’m looking for how to disable.
I reffered ‘https://devtalk.nvidia.com/default/topic/973698/?comment=5008653

I saw error ‘-su: echo: write error: Permission denied’ when …

$ sudo su -

echo 1 > /sys/kernel/debug/30c0000.watchdog/disable_dbg_reset

Are there any way for?

Best regards,
fulc_mt

I’ve encountered issues such as this as well, so I do not have an answer. I was hoping someone from NVIDIA has been able to get the Trace32 working on a TX2 and could post details. If not, then perhaps just posting what caused an inability to use the Trace32 would be nice to know.

I am also curious if anyone knows of any other brand of JTAG debugger which might do a better job on the TX2.

Still interested in this thread if anyone knows about JTAG debugging on a TX2.

Hi all
The script for TX2 will be out on next release.

linuxdev,
Another option is to check for TRACER32 site and here is what I found,

http://www.lauterbach.com/frames.html?home.html (search for tegrax2)

"Software Updates

SW-Update not available for TEGRAX2. Please request for an Interim build on www.lauterbach.com/tsupport.html

Interim builds are produced on a regular basis and contain all new TRACE32 features;
mainly the support for new chips, new compiler versions or new target OSes. Interim builds only passed basic tests.

I would be interested to know a rough price for the debugger if possible, LinuxDev!

In case anyone is still looking for this answer. Disable the hardware watchdog on TX2 as follows:

/ {
	plugin-manager {
		/delete-node/ fragement@0;   // disable denver watchdog
	};
};

With this change and Nvidia’s Lauterbach scripts, Trace32 debugging works well for me. I haven’t gotten the “Linux awareness” working though.