TX2 NX DP0 no sound

Hi,

We are using TX2-NX pre-build image on customer board with DP0.
There is no HDMI sound device on Desktop (system setting->sound), but show only “Dummy Output” device
ALSA device list:
[ 11.299183] #0: tegra-hda at 0x3518000 irq 378

To use same customer board by nx module with pre-build image, DP0 sound is fine.

Do anyone know what’s going wrong?

Hi,

I am not quite sure the request here. Are you talking about you make a custom board with HDMI port on SOR0 and it has no sound?

To use same customer board by nx module with pre-build image, DP0 sound is fine.

What kind of pre-build image is that? sdcard image? or something else?

Hi Wayne,

My carrier board design as beneath , pin 88/59/57/53/51/47/45/41/39/92/90 is DP function

DP display output fine, but without sound feature.

We use nvidia binary, flash image with jetson-xavier-nx-devkit-tx2-nx config to eMMC
$ sudo ./flash.sh jetson-xavier-nx-devkit-tx2-nx mmcblk0p1

Regards

Hi @yi-chia.lan,

  1. Then why did you mention HDMI if there is totally no HDMI here?
  2. Please share the dmesg
  3. To use same customer board by nx module with pre-build image, DP0 sound is fine.

What is the exact “pre-build imager” here? Who provides this to you? From NV?

Hi WayneWWW,

  1. please find tx2-nx.log for dmesg
    tx2-nx.log (79.7 KB)

  2. pre-build image means download L4T Driver Package (BSP) from nvidia download center.
    untar Jetson_Linux_R32.6.1_aarch64.tbz2 and navigate to Linux_for_Tegra, flash image with jetson-xavier-nx-devkit-tx2-nx config

Hi,

Are you talking about “TX2-NX” does not have audio setting but “NX” has? or you are talking about something else?

Hi WayneWWW.

Yes, TX2-NX does not have audio setting.

NX has

Hi,

I can see the same behavior on the devkit too. Will check.

To use audio, you can use the command line first.

$ aplay -Dhw:tegrahda,3 test_stereo_44100Hz_16bit_PCM.wav

Please use you own audio file to test here.

Hi WayneWWW,

Using command, no audio either.
$ aplay -Dhw:tegrahda,3 /usr/share/sounds/alsa/Front_Right.wav
Playing WAVE ‘/usr/share/sounds/alsa/Front_Right.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1305: Channels count non available

$ aplay -Dhw:tegrahda,7 /usr/share/sounds/alsa/Front_Right.wav
Playing WAVE ‘/usr/share/sounds/alsa/Front_Right.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
aplay: set_params:1305: Channels count non available

Hi,

Could you validate your command on TX2-NX devkit first?

Hi yi-chia.lan,

Please run below command to check your TX2-NX audio device:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: tegrahda [**tegra-hda**], device **3**: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: tegrahda [tegra-hda], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Hi carlyuu,

Here is my audio device:
image

Hi yi-chia.lan,

Can you try play other wav files?

Hi carlyuu,

To try other wav file and by command : aplay -Dhw:tegrahda,3 demo.wav , audio sound come out successfully.

1 Like

Hi yi-chia.lan,

Thanks for check.
We will checking no HDMI/DisplayPort sound setting with DP port issue.

Please add one more device to /usr/share/alsa/cards/tegra-hda.conf and see if it works.

tegra-hda-galen.pcm.hdmi.0 {
    @args [ CARD AES0 AES1 AES2 AES3 ]
    @args.CARD { type string }
    @args.AES0 { type integer }
    @args.AES1 { type integer }
    @args.AES2 { type integer }
    @args.AES3 { type integer }
    type hooks
    slave.pcm {
        type hw
        card $CARD
        device 3
    }
    hint.device 3
}

Hi WayneWWW,

Yes, it works.
Thanks~

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.