TX2 NX Pinmux problem

Hello. I want to use the four pins of TX2 NX’s UART1 as GPIO, so I changed PINMUX’s UART1 configuration option.When changing the Pin Direction of “UART1_TXD” to “Bidirectional”, an error occurs.
207 UATR1_RTS*
209 UATR1_CTS*

hello chao.zhang,

there should be error messages to indicate the corresponding settings you may configured.
please update all the settings accordingly.

When configured as “Bidirectional”, only the following messages are displayed.

hello chao.zhang,

this pin cannot configure as bidirectional, please set it as Output and disable wake pin.

OK.Thanks.And can 205 207 209 be configured as “Bidirectional” as a GPIO?I configured these three pins as “Bidirectional” “Int PU”,As a result, the input, output, high level and low level of the pin cannot be controlled.
tegra186-p3636-0001-p3509-0000-a01.dts (2.8 KB)

dmesg.txt (57.6 KB)

hello chao.zhang,

please access Jetson TX2 NX Product Design Guide, and you should refer to [11.5 UART] chapter.
there’s footnote to indicate those TX signals, such as pin-203/UART1_TXD, it can only be used as output if configured as GPIOs.

Ok, thanks

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.