TX2 Pinmux DT file generation problem

I’ve just updated the TX2 Pinmux for a new carrier board that we have designed. The pinmux spreadsheet looks good with no error cells highlighted.
However when I try to generate the DT file it throws up an error:

“You made an invalid choice. Please check your configuration.”

As I said there are no cells with error highlights. Don’t know how to proceed from here.

Thanks in advance.

Hello again. Is there some way that I can attach my updated pinmux file to this discussion topic so that someone could have a look?

Marvin IO board Master TX2 pinmux_14012019.xlsx (749 KB)

You cannot attach to a post while creating it. You can attach to a preexisting post. If you hover your mouse over the upper right corner’s “quote” icon you will see a paper clip icon show up. The paper clip icon allows you to attach a file (not all formats are accepted, but you could rename it with a “.txt” suffix for a source code device tree if that is the case).

Do you run the spreadsheet on a Windows host?

Thanks to all for replying.

I cannot attach the .xlsm (excel file with embedded macro) version. However it will allow me to attach a regular xlsx file. Don’t know if that would be of any benefit. In any case I have attached that to my last post above.

Yes I run the spreadsheet on a windows host PC. Is that an issue? We do have Linux machines etc here.

Thanks again for the help.

After checking your pinmux, I guess you have some error setting.
Could you share what pin you’ve modified?

Thanks for getting back.
I changed a lot of pins but mostly these are just no connects. Do you want me to send you a full list of everything I changed?
Have there been any other reports of spreadsheets (without error highlights) not compiling?

Could you just try

  1. With default spreadsheet, try to create config.
  2. Modify/Disable some pins and see if it is still working?

This morning I took the default spreadsheet and started to modify it block by block and doing a compile each time. I was hoping that that approach would isolate the problem area.
In any case I proceeded through the default file piece by piece, compiling along the way.
It worked every time so now I have a successful compile with all the original changes in.
The only thing that I didn’t do this time round was to edit the comment in column BC i.e. “Customer Usage Description or Net Names”

First time that I modified the spreadsheet I did it all in one go and then tried to compile. Essentially the two files are the same now (except for the comments) so I don’t know why it did not compile the first time.

In any case it looks like I’m OK now.
Thanks for your help.