TX2, rtc, not enabled

TX2 board, i set the date to 2021-3-13:9:43, when i reboot the board, the date returns to 2018-01-29 23:59。
so there is no rtc on board? but there is rtc0 and rtc1 under /dev,
is there any way to resolve the isuue? i do not connect wifi or ethernet.

hello zsjalive,

may I know which JetPack release you’re working with?
please check release tag for details, for example, $ cat /etc/nv_tegra_release
may I know your complete steps to reproduce the issue, assume you’re using system configuration user-interface for setting system-time?

jetpack4.4(L4T 32.4.3)
$ cat /etc/nv_tegra_release

R32 (release), REVISION: 4.3, GCID: 21589087, BOARD: t186ref, EABI: aarch64, DATE: Fri Jun 26 04:34:27 UTC 2020

Hi zsjalive,

Can you set time with timedatectl commands?

$ timedatectl status
$ timedatectl set-ntp 0
$ timedatectl set-time 2021-03-13
$ timedatectl set-time 9:43:30

After reboot → check status again.

1.i used timedate cmd to set time
2. reboot, system time is good as i set .
3.i powered off the board, it does not work,time return to original(2018-01-29 00:00:00), so ,can you help me to resolve the issue?

you can repeat the problen with your own board

hello zsjalive,

may I know what’s the commands you’re used for step-3? or, you’d disconnected power-supply to fully power-off the board?

hi ,i disconnected power-supply to fully power-off the board for step 3.

Hi zsjalive,

Before disconnected power supply, please enable network time synchronization.

$ timedatectl set-ntp 1

hi,it does not work yet

hello zsjalive,

could you please share $ timedatectl status before and after you fully power-off the board.

hello zsjalive,

by the way,
did you complete system time setting and disconnected power supply immediately?
it should be settings that only remain with user-space application.

could you please have a try to execute time clocks utility in the last for pmic register updated those new values.
for example, $ hwclock -uw

hi, the first pic is for set time, the second pic is after power disconnect and then power on! but it is not correct.

hello zsjalive,

FYI, we are not able to reproduce this issue locally with/without ethernet.
do you have any modifications, are you installing JetPack release via SDKManager?

hi ,i install jetpack4.4 via SDKmanager. i did not modify anything.
i did not connect wifi or internet
does this cause the issue???
is is possible the key is timezone,but i am not sure. i have no idea how to verify.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

hello zsjalive,

may ask you for more trial and errors since we’re not able to reproduce the issue locally.
could you please change the location as other time zone for verification?