TX2 struggles to connect to the internet

My TX2 has a few problems regarding connecting to the internet.

First of all, it cannot detect one of the two wifi networks we have.

Second, I cannot connect to most websites. I can reach google, and load google results, but clicking on any link almost always results in a message that it cannot connect to the host server.

Third, when I can connect it is very slow, far below the limitations of the wifi or ethernet connections.

I have tried to find a firewall that might be preventing certain sites from being reached but there doesnt appear to be one. I have tried with Chrome, Firefox, and the terminal on wifi and ethernet. None of these appear to affect the connection abilities.

Im not sure if this something to do with my environment setup or specifically related to the TX2 but if anyone has had this problem or knows how I might go about diagnosing it better, any help would be greatly appreciated!

edit: fixed this by removing static IP

Sorry, sent this before your edit, but perhaps still useful for people with network problems :P

One thing you might need to do is determine if it is a DNS issue (name-to-address translation), or something else…route issues.

The old command line DNS lookup is "nslookup ", the newer one is "host ". Example:

ubuntu@tegra-ubuntu:~$ host nvidia.com
nvidia.com has address 216.228.121.209
nvidia.com mail is handled by 10 hqemgate09.nvidia.com.
nvidia.com mail is handled by 10 hqemgate08.nvidia.com.
nvidia.com mail is handled by 10 nvidiahk.nvidia.com.

If this returns quickly, then you can rule out DNS issues. If you run this command against a web site you are trying to get to, and can look up quickly, then this means at least half is working well. In that above sample you could either go to the web site at nvidia.com or 216.228.121.209.

Another example:

ubuntu@tegra-ubuntu:~$ host devtalk.nvidia.com
devtalk.nvidia.com is an alias for laack.x.incapdns.net.
laack.x.incapdns.net has address 192.230.66.99

…which implies that if not for web server mechanics and SSL certificates that you could find this thread via either:
https://devtalk.nvidia.com/default/topic/1027538/jetson-tx2/tx2-struggles-to-connect-to-the-internet/
https://192.230.66.99/default/topic/1027538/jetson-tx2/tx2-struggles-to-connect-to-the-internet/
…this latter address goes to the same server, but security will prevent it from being interchangeable.

Try this with “ping” of addresses you can find after looking up a name…see if ping is fast or slow.

thanks for your reply anyways!

hi tyleruidyh,
could you please help me with your solution? I’ll really appreciate it
I’ve been with the same problems you described for a long time and now I want to solve this for real. I’ve tried dynamic IP and static IP, nothing works… is there anything else in your router configuration or in your networks configuration that I should look at?
Thanks and regards,
Boris

You should probably start a new topic since this is many years old, but when you do, include the following information:

  • Output of “ifconfig”.
  • Output of “iwconfig”.
  • Output of “route”.
  • If there is a ordinary router, versus if it is only going through a host PC.
  • Basically, what the device is wired to, e.g., wired ethernet to a router.

Thanks for the suggestions @linuxdev . I’m working with the TX2 module (not in the development kit) and I’m trying to connect to my home router. In all other devices I’m getting a strong signal and connection to the internet.
I just realized that I should try to use the cables+antennas from the development kit… that works it seems. The signal is stronger now :)
Sorry for the stupid question when the solution was much simpler.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.